HUMAnN conda installation dependency issues

Hi all,

I don’t really need help, but I wanted to document this issue in case it could inform documentation, or in case others run into it.

I was able to install HUMAnN v3.6 using conda on a new server, and it passed all tests, but when actually using it on my data it would fail with the following error:
CRITICAL ERROR: Please update diamond from version 0.9.24 to version 2.0.15.

I was reading about your update to diamond>=v2.0.15 in HUMAnN v3.6, so I was a bit confused why it’s possible for conda to install an old version of diamond (in a fresh environment) and for that version of diamond to pass all tests.

Within my conda environment, I tried updating diamond using both conda and pip and trying multiple channels, but there were always dependency issues. After narrowing down on a few issues, the one dependency that’s sticking around is the weird glibc issue below.

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Output in format: Requested package → Available versionsThe following specifications were found to be incompatible with your system:

  • feature:/linux-64::__glibc==2.17=0
  • feature:|@/linux-64::__glibc==2.17=0

Your installed version is: 2.17

From what I’ve read, others have had similar issues with a metaphlan install here and with other packages (cudatoolkit example), where it’s helpful to prioritize conda-forge. I think this has solved my issue, so I wanted to document it in case others come across it.

However, when doing so using conda, it’s gotten stuck solving the environment (running > 1 hr). Instead, I tried using mamba, which worked almost immediately (I’m still waiting on conda to solve the environment as I write this). I used the command mamba install -c biobakery -c conda-forge humann in a fresh environment. In case others are struggling with conda solving the environment, I wanted to document that mamba solved mine in a fraction of the time that conda did. It could be helpful to recommend mamba as an alternative to conda on the installation documentation?

In summary:

  • For some reason, conda sometimes will install an incorrect version of diamond for HUMAnN v3.6? I think this might have been because I hadn’t set up the proper channel priorities, but it could be something to look out for.
  • Trying to install the correct version of diamond resulted in dependency issues. Prioritizing conda-forge may help with resolving these, but conda takes a very long time to do so.
  • Mamba has worked much better than conda for me installing HUMAnN v3.6 without dependency/version issues. I’m not sure how universal my experience is, but it might be worth suggesting mamba for users having issues with conda installs or dependencies.

If you have any advice on something I might be doing wrong that led to these issues, please let me know, but I think I’ve found a workaround through mamba for now.


Thank you @sterrettJD I have been having this issue with dowloading the whole biobakery package as well (got the metaphlan error and then when downloading metaphlan I get the glibc error).
Will try the mamba route!