The bioBakery help forum

Diamond version error

Hello, I use install HUMAnN by:

conda install -c biobakery humann

Then download database.

When I run HUMAnN, I see:

11/09/2020 05:41:50 PM - humann.utilities - DEBUG: Check software, diamond, for required version, 0.9.24
11/09/2020 05:41:50 PM - humann.utilities - CRITICAL: Can not call software version for diamond


$ diamond --version
diamond version 2.0.4

$ diamond dbinfo --db uniref90_201901.dmnd
diamond v2.0.4.142 (C) Max Planck Society for the Advancement of Science
Documentation, support and updates available at

Database format version = 2
Diamond build = 125
Sequences = 87296736
Letters = 29247941583

$ diamond getseq -d uniref90_201901.dmnd | rg "^>" | wc -l

From this,,

I think diamond meets the version requirements.

Any help ? Thanks very much.

1 Like

Hello, Thank you for the detailed post and sorry for any confusion. HUMAnN is compatible with diamond version 0.9.24 but not yet with the latest diamond v2. If you would roll back your diamond version it should resolve the errors you are seeing.

Thank you,


Thanks very much. Solved.

I have questions when using humann2
It showed
"Running diamond …

Aligning to reference database: uniref90_annotated.1.1.dmnd

CRITICAL ERROR: Error executing: /gpfs/share/home/1901111783/miniconda2/envs/humann2/bin/diamond blastx --query /gpfs/share/home/1901111783/meta/temp/p136C_humann2_temp/p136C_bowtie2_unaligned.fa --evalue 1.0 --threads 1 --max-target-seqs 20 --outfmt 6 --db /gpfs/share/home/1701111743/db/humann2/uniref/uniref90_annotated.1.1 --out /gpfs/share/home/1901111783/meta/temp/p136C_humann2_temp/tmpmcMUXV/diamond_m8_UmaiPA --tmpdir /gpfs/share/home/1901111783/meta/temp/p136C_humann2_temp/tmpmcMUXV

" Error message returned from diamond :
diamond v0.8.36.98 | by Benjamin Buchfink
Check for updates."

It seems that the diamond version is not right. However, I checked the diamond version requirement in website. It is ok when diamond version is from 0.8.22 to 0.9. My diamond version is right, my diamond version is, but the error say my diamond needs updates. I am very confused about this error. Thanks for your help!!

1 Like

The same error as yours. But I’ve not found a solution for it

Hello, Sorry for the slow response. You are right that HUMAnN v2 expects those diamond versions listed. HUMAnN checks the diamond version at the beginning and will issue a warning if the version does not match that expected. Did you see a warning message? It looks like from your post the error is during the diamond run. Does the diamond message include more information and if so can you post? Sorry again for the slow reply.

Thank you,

Hello, Can you provide more information about the error that you see? If you could include the error output from diamond that would be great.

Thank you,

Hello Lauren,
I have came across similar error message too. Looks like diamond 0.9.24 is not compatible with humann3.
not sure what shall I do…

I am also having issues when running humann. My specific error is:

humann --input 6070_08-30-17_1.fq.gz --output /labs/asbhatt/rbrewster/gvhd/humann3/

WARNING: Can not call software version for bowtie2

CRITICAL ERROR: Can not call software version for diamond

This was returned when trying both diamond versions 0.9.24 and 0.9.36. Interestingly, the UniRef90 database seems to only be compatible with version 0.9.36. Thanks in advance for any support you can provide!

Sorry for the late reply - this feels like a separate issue: something is preventing HUMAnN from calling (e.g.) bowtie2 --version during testing. Are you able to execute that command from a terminal? If so, what does it return?

Hi @YikeShen , Thank you for the detailed error message. If you upgrade your diamond install to v0.9.36 it should resolve the error you are seeing.

Thank you,

1 Like