Diamond error with humann3

I install the Humann3 and tried to run it and then came across with an error for diamond.

CRITICAL ERROR: Can not call software version for diamond

Then I went and download the diamond version 0.9.36 and tried to run it gives this error again. I downgraded to 0.9.24 version, Then I get an error to update to 0.9.36 version.

When I try to get version as diamond --version. I get an error: Illegal instruction (core dumped).

None of the suggestions on the forum solved my problem.

Could you please help with that?
Thank you.

Are you able to run diamond --version from the command line? I.e. outside of HUMAnN? I’m wondering if there is something wrong with your environment/DIAMOND build that is leading to this error.

If I download the version 9.24, yes I am able to run the command line diamond --version within conda. But if I upgrade to 9.36 then the error is Illegal instruction (core dumped). Even though I have no problem during the upgrade 9.36 (no error), for some reason it is not recognized.