Diamond error humann

I am using Humann3 installed via the biobakery conda channel. I am receiving an error when diamond attempts to run. I have tried running fewer threads and receive the same error message. It seems this issue has been raised several times before without a definitive answer. Thank you for your help!

Running diamond …

Aligning to reference database: uniref90_201901b_full.dmnd

CRITICAL ERROR: Error executing: /home/seth2/miniconda3/envs/biobakery/bin/diamond blastx --query /media/seth2/Toshiba/CAZ/trimmed-merged/test7/SRR6897673_trimmed-merged_humann_temp_kzwqs_gn/SRR6897673_trimmed-merged_bowtie2_unaligned.fa --evalue 1.0 --threads 8 --top 1 --outfmt 6 --db /media/seth2/Toshiba/humann_db3/uniref/uniref90_201901b_full --out /media/seth2/Toshiba/CAZ/trimmed-merged/test7/SRR6897673_trimmed-merged_humann_temp_kzwqs_gn/tmp34olbi59/diamond_m8_badq1b99 --tmpdir /media/seth2/Toshiba/CAZ/trimmed-merged/test7/SRR6897673_trimmed-merged_humann_temp_kzwqs_gn/tmp34olbi59

Error message returned from diamond :

diamond v2.0.15.153 (C) Max Planck Society for the Advancement of Science

Documentation, support and updates available at http://www.diamondsearch.org

Please cite: http://dx.doi.org/10.1038/s41592-021-01101-x Nature Methods (2021)

#CPU threads: 8

Scoring parameters: (Matrix=BLOSUM62 Lambda=0.267 K=0.041 Penalties=11/1)

Temporary directory: /media/seth2/Toshiba/CAZ/trimmed-merged/test7/SRR6897673_trimmed-merged_humann_temp_kzwqs_gn/tmp34olbi59

Percentage range of top alignment score to report hits: 1

Opening the database… [0.078s]

Database: /media/seth2/Toshiba/humann_db3/uniref/uniref90_201901b_full.dmnd (type: Diamond database, sequences: 87296736, letters: 29247941583)

Block size = 2000000000

Opening the input file… [0.032s]

Opening the output file… [0s]

Loading query sequences… [15.531s]

Masking queries… [16.648s]

Algorithm: Double-indexed

Building query histograms… [11.301s]

Allocating buffers… [0s]

Loading reference sequences… [4.43s]

Masking reference… [11.56s]

Initializing dictionary… [0.016s]

Initializing temporary storage… [0s]

Building reference histograms… [13.15s]

Allocating buffers… [0s]

Processing query block 1, reference block 1/15, shape 1/2, index chunk 1/4.

Building reference seed array… [3.882s]

Building query seed array… [2.453s]

Computing hash join… [2.097s]

Masking low complexity seeds… [0.618s]

Searching alignments… Input/output error

terminate called after throwing an instance of ‘File_write_exception’

what(): Error writing file /media/seth2/Toshiba/CAZ/trimmed-merged/test7/SRR6897673_trimmed-merged_humann_temp_kzwqs_gn/tmp34olbi59/diamond-tmp-dvw9PF


Thank you for the detailed post with the full error message! With the write error, it looks like you might be running out of space. Can you check on disk space and see if this might be the issue?

Thank you,