HUMAnN 3.8 error opening file ._uniref90_201901b_ec_filtered.dmnd

I am trying to run humann v3.8, using:

$ humann --input test_humann.fastq --output test_humann --threads 4 --nucleotide-database ~/databases/chocophlan --protein-database ~/databases/uniref

There was no problem until diamond started running, and this is the output that I got:

Running diamond …

Aligning to reference database: uniref90_201901b_ec_filtered.dmnd

Aligning to reference database: ._uniref90_201901b_ec_filtered.dmnd

CRITICAL ERROR: Error executing: /opt/homebrew/bin/diamond blastx --query ~/test_humann/test_humann_humann_temp/test_humann_bowtie2_unaligned.fa --evalue 1.0 --threads 3 --top 1 --outfmt 6 --db ~/databases/uniref/._uniref90_201901b_ec_filtered --out ~/test_humann/test_humann_humann_temp/tmp0lo4zgea/diamond_m8_y7zt4crb --tmpdir ~/test_humann/test_humann_humann_temp/tmp0lo4zgea

Error message returned from diamond :

diamond v2.1.8.162 (C) Max Planck Society for the Advancement of Science, Benjamin Buchfink, University of Tuebingen

Documentation, support and updates available at

Please cite: Sensitive protein alignments at tree-of-life scale using DIAMOND | Nature Methods Nature Methods (2021)

#CPU threads: 3

Scoring parameters: (Matrix=BLOSUM62 Lambda=0.267 K=0.041 Penalties=11/1)

Temporary directory: ~/test_humann/test_humann_humann_temp/tmp0lo4zgea

Percentage range of top alignment score to report hits: 1

Opening the database…

Error opening file ~/databases/uniref/._uniref90_201901b_ec_filtered: No such file or directory

What is the “.uniref90_201901b_ec_filtered” file and why is it needed? To my understanding, filenames that begin with “.” indicate hidden or temporary files, so I checked and there was no file of that name in the database directory. There is only 1 file in the ~/databases/uniref directory, which is uniref90_201901b_ec_filtered.

Did I do something wrong?
I am quite new to this and I appreciate any help.

P/s in case it might be useful: I downloaded the uniref90_201901b_ec_filtered database using my web browser since the command humann_databases --download only downloaded about a half then failed.

Hello, Thank you for the detailed error message. I wonder if maybe this is because of an issue with the downloads. I agree the code does not need a “.” file. Can you check the contents of the folder “~/databases/uniref/”? It should contain a file named “uniref90_201901b_ec_filtered.dmnd”. If it does not, can you remove the folder and try downloading again? I think this should resolve the issue.


Hi, thanks for your reply. I tried downloading using the command humann_databases --download and it did resolved the issue.
I didn’t think of this since diamond had run for about 6 hours before the error message regarding the “.__uniref90_201901b_ec_filtered.dmnd” file appeared. It works now. Thank you so much.

Best regards,

Thanks for the follow up! I am so glad to hear you are all set!