Diamond UniRef90 database error

Hello,

I am using the HUMAnN v.3.1.0. Because of an eeror I have encountered, I manually downloaded the Uniref90 database from your repository, named “uniref90_annotated_v201901b_full.tar.gz”, same name while I was trying to use the command;

humann_databases --download uniref uniref90_diamond $INSTALL_LOCATION

and I completed configuration of the downloaded and unzipped diamond database without any error. However, when I attempted to use humann code, I am getting the error message;

CRITICAL ERROR: The directory provided for the translated database contains files ( uniref90_201901b_full.dmnd ) that are not of the expected version. Please install the latest version of the database: v201901_v31
and I could not find that version on (Index of /humann_data/uniprot/uniref_annotated/).
Could you please guide me how to solve the issue?

Thank you,

Best regards.

Please see the release notes for v3.1 and let us know if following the install/upgrade instructions there helps to resolve your error:

https://forum.biobakery.org/t/announcing-metaphlan-3-1-and-humann-3-1/3881/2

Dear @franzosa,

Thank you for your quick reply.

I created environment and installed the biobakery3. When I tried to build databases,

humann_databases --download uniref uniref90_diamond
 "/runspace/eraysahin/uniref/" --update-config yes

Download URL: http://huttenhower.sph.harvard.edu/humann_data/uniprot/uniref_annotated/uniref90_annotated_v201901b_full.tar.gz
Downloading file of size: 19.17 GB

CRITICAL ERROR: Unable to download and extract from URL: http://huttenhower.sph.harvard.edu/humann_data/uniprot/uniref_annotat
ed/uniref90_annotated_v201901b_full.tar.gz

Got that error for Chocophlan and utility mapping as well. Therefore, downloaded each file from the repository manually, unzipped them and set the database path to the folders involving those files.

In the release notes, it has been indicated that there is no need to update diamond databases. And I could not find a diamond dtb version with a ‘…_v31’ in the name. That is written in Chocoplan’s new version.

Best,

Thanks for pointing this out. The software looking for an updated translated database was indeed an error on our end. We have just published HUMAnN v3.1.1 to correct this (v3.1.1 is available via pypi and docker now and will be available via conda later today). To be clear: unlike the pangenome database, the translated (protein) databases DO NOT change in v3.1, consistent with what was said in the v3.1 release notes, but the software itself needed a small change to account for this fact. Apologies for the confusion!

The separate issue you encountered downloading the databases is a limitation of our hosting service. I’m glad the manual downloads worked out for you!

Great news. I appreciate for your effort and help.

Best regards.