The bioBakery help forum

Tutorial is listing the wrong docker container

The tutorial lists the docker container for metaphlan3,which did indeed have strainphlan3.0, but was missing samtools, ncbi-blast+, raxml, mafft, and the phylophlan config directory. I was eventually successful at running through the tutorial after updating bionic and source installing the deps, at which point I realized that maybe I had originally pulled the wrong container. After a quick search on dockerhub I found the strainphlan container, which worked flawlessly right out of the docker pull.

Can you perhaps update the strainphlan3 wiki to reflect the correct docker container? I tried making a pull request, but I ran into some permissions issues, and I’m not exactly sure how that works with the wiki’s.
-$ docker pull biobakery/metaphlan
+$ docker pull biobakery/strainphlan

Also I fixed a typo in the add_metadata_tree.py script where the directory was mislabeled as fastqs instead of fastq.

-add_metadata_tree.py -t output/RAxML_bestTree.s__Bacteroides_caccae.StrainPhlAn3.tre -f fastqs/metadata.txt -m subjectID --string_to_remove .fastq.bz2
+add_metadata_tree.py -t output/RAxML_bestTree.s__Bacteroides_caccae.StrainPhlAn3.tre -f fastq/metadata.txt -m subjectID --string_to_remove .fastq.bz2

Hi @MADscientist314 ,
Thanks for reporting this problems. You are right, the correct docker for strainphlan is biobakery/strainphlan since this one has all the dependencies installed, biobakery/metaphlan has all the strainphlan script but no dependencies. I will make these amends in the wiki asap.
Thanks!

1 Like