HuManN v4 output are different

Hello to everyone!

I downloaded HuManN from the GitHub web site (GitHub - biobakery/humann: HUMAnN is the next generation of HUMAnN 1.0 (HMP Unified Metabolic Analysis Network).) so I should have the version number 3 but when I check (humann --version) I have the v4.0. Do you know why?

When I run my data the output are a bit different, I do not have the pathway coverage file but a reactions file.

Also when I look at my gene family file, I just have I species and a t_ that I do not understand what is, where I can find the family and the gender?

Thank you!

I had the same issue before. I think you should install through conda instead.

Indeed, it sounds like you pulled the HUMAnN 4 alpha source code, but we have not published the full databases for HUMAnN 4 yet, so you’d only be seeing demo-style output.

Ok thank you! Also because when I run it I have the errore that the version vOct22 does not have the head line but I would like to use the version vJun23 (202403) for Metaphlan. How I can do? I have to wait for the new version?

Sorry I’m not following your question. You want to use the newest MetaPhlAn with the newest MetaPhlAn database? If so, that is discussed here:

No, sorry if I do not explain myself correctly. I want to use humann 3.9 with the vJun23_202403 database version of Metaphlan but I don’t know if it is possible.