The bioBakery help forum

Conda install humann failed

Hello
I’m trying to install humann3 with conda and the command for this is the following
conda create -n humann3 python=3.7
conda activate humann3
conda install humann -c biobakery

And got the following errors
Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.
Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: -
Found conflicts! Looking for incompatible packages.
This can take several minutes. Press CTRL-C to abort.
failed

UnsatisfiableError: The following specifications were found to be incompatible with each other:

Package pip conflicts for:
python=3.7 -> pip
Package tk conflicts for:
python=3.7 -> tk[version=’>=8.6.7,<8.7.0a0|>=8.6.8,<8.7.0a0’]
Package openssl conflicts for:
python=3.7 -> openssl[version=’>=1.0.2o,<1.0.3a|>=1.0.2p,<1.0.3a|>=1.1.1a,<1.1.2a|>=1.1.1b,<1.1.2a|>=1.1.1c,<1.1.2a|>=1.1.1d,<1.1.2a|>=1.1.1e,<1.1.2a|>=1.1.1g,<1.1.2a’]
Package ncurses conflicts for:
python=3.7 -> ncurses[version=’>=6.1,<7.0a0|>=6.2,<7.0a0’]
Package libffi conflicts for:
python=3.7 -> libffi[version=’>=3.2.1,<3.3a0|>=3.3,<3.4.0a0’]
Package readline conflicts for:
python=3.7 -> readline[version=’>=7.0,<8.0a0|>=8.0,<9.0a0’]
Package xz conflicts for:
python=3.7 -> xz[version=’>=5.2.4,<6.0a0|>=5.2.5,<6.0a0’]
Package python_abi conflicts for:
humann -> python_abi=3.7[build=*_cp37m]
Package ld_impl_linux-64 conflicts for:
python=3.7 -> ld_impl_linux-64
Package libgcc-ng conflicts for:
python=3.7 -> libgcc-ng[version=’>=7.2.0|>=7.3.0’]
Package libstdcxx-ng conflicts for:
python=3.7 -> libstdcxx-ng[version=’>=7.2.0|>=7.3.0’]
Package zlib conflicts for:
python=3.7 -> zlib[version=’>=1.2.11,<1.3.0a0’]
Package metaphlan conflicts for:
humann -> metaphlan[version=’>=3.0.0.alpha’]
Package diamond conflicts for:
humann -> diamond[version=’>=0.9.24’]
Package bowtie2 conflicts for:
humann -> bowtie2[version=’>2.1’]
Package sqlite conflicts for:
python=3.7 -> sqlite[version=’>=3.24.0,<4.0a0|>=3.25.2,<4.0a0|>=3.25.3,<4.0a0|>=3.26.0,<4.0a0|>=3.27.2,<4.0a0|>=3.29.0,<4.0a0|>=3.30.1,<4.0a0|>=3.31.1,<4.0a0’]
Package glpk conflicts for:
humann -> glpk

Please help me with this!

Hello, Sorry to hear you are having issues installing HUMAnN v3 with conda. I think if you configure your channels it might resolve the dependency errors you are seeing. Please try the commands included below before installing HUMAnN.

Thank you,
Lauren

$ conda config --add channels defaults
$ conda config --add channels bioconda
$ conda config --add channels conda-forge
$ conda config --add channels biobakery

$ conda install -c biobakery humann

Thanks for the reply!
Installation was successful but I had another error to run demo file
Here is the command that I use

humann -i demo.fastq -o sample_results

And the following is the message and errors

Creating output directory: /gpfs/scratch1/7/kim45/test/sample_results

Output files will be written to: /gpfs/scratch1/7/kim45/test/sample_results

WARNING: Can not call software version for bowtie2

Running metaphlan …

CRITICAL ERROR: Error executing: /nv/hp10/kim45/.conda/envs/humann3/bin/metaphlan /gpfs/scratch1/7/kim45/test/demo.fastq -t rel_ab -o /gpfs/scratch1/7/kim45/test/sample_results/demo_humann_temp/demo_metaphlan_bugs_list.tsv --input_type fastq --bowtie2out /gpfs/scratch1/7/kim45/test/sample_results/demo_humann_temp/demo_metaphlan_bowtie2.txt

Error message returned from metaphlan :

Downloading https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AAA4XDP85WHon_eHvztxkamTa/file_list.txt?dl=1

Downloading file of size: 0.00 MB

0.01 MB 232.33 % 14.57 MB/sec 0 min -0 sec

Downloading https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AAAyoJpOgcjop41VIHAGWIVLa/mpa_latest?dl=1

Downloading file of size: 0.00 MB

0.01 MB 31507.69 % 20.13 MB/sec 0 min -0 sec

Downloading MetaPhlAn database

Please note due to the size this might take a few minutes

File /nv/hp10/kim45/.conda/envs/humann3/lib/python3.7/site-packages/metaphlan/metaphlan_databases/file_list.txt already present!

Traceback (most recent call last):

File “/nv/hp10/kim45/.conda/envs/humann3/bin/metaphlan”, line 10, in

sys.exit(main())

File “/nv/hp10/kim45/.conda/envs/humann3/lib/python3.7/site-packages/metaphlan/metaphlan.py”, line 1187, in main

pars[‘index’] = check_and_install_database(pars[‘index’], pars[‘bowtie2db’], pars[‘bowtie2_build’], pars[‘nproc’], pars[‘force_download’])

File “/nv/hp10/kim45/.conda/envs/humann3/lib/python3.7/site-packages/metaphlan/metaphlan.py”, line 610, in check_and_install_database

download_unpack_tar(FILE_LIST, index, bowtie2_db, bowtie2_build, nproc)

File “/nv/hp10/kim45/.conda/envs/humann3/lib/python3.7/site-packages/metaphlan/metaphlan.py”, line 463, in download_unpack_tar

url_tar_file = ls_f[“mpa_” + download_file_name + “.tar”]

KeyError: ‘mpa_mpa_v30_CHOCOPhlAn_201901.tar’

FYI, when I typed bowtie2 --version, It printed

/nv/hp10/kim45/.conda/envs/humann3/bin/bowtie2-align-s version

64-bit

Built on

Sat Jun 6 20:17:22 UTC 2020

Compiler: gcc version 7.5.0 (crosstool-NG 1.24.0.123_1667d2b)

Options: -O3 -msse2 -funroll-loops -g3 -fvisibility-inlines-hidden -std=c++17 -fmessage-length=0 -march=nocona -mtune=haswell -ftree-vectorize -fPIC -fstack-protector-strong -fno-plt -O2 -ffunction-sections -pipe -isystem /nv/hp10/kim45/.conda/envs/humann3/include -fdebug-prefix-map=/opt/conda/conda-bld/bowtie2_1591474367590/work=/usr/local/src/conda/bowtie2-2.4.1 -fdebug-prefix-map=/nv/hp10/kim45/.conda/envs/humann3=/usr/local/src/conda-prefix -DPOPCNT_CAPABILITY -DWITH_TBB -std=c++11 -DNO_SPINLOCK -DWITH_QUEUELOCK=1

Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}

Thanks in advance!

Hello I just resolved this issue and it works now.
Thanks!

These have been added to the official release notes at:

https://huttenhower.sph.harvard.edu/humann3/