Unable to download MetaPhlAn 4 database

MetaPhlAn version 4.1.0 (23 Aug 2023)

I’ve tried with severall commands:

  1. metaphlan --install
  2. metaphlan --install --bowtie2db
  3. wget --continue --limit-rate=20M http://cmprod1.cibio.unitn.it/biobakery4/metaphlan_databases/bowtie2_indexes/mpa_vJun23_CHOCOPhlAnSGB_202307_bt2.tar

While all of the command end up with a very slow download speed (0.03mb/s), which stop downloading (as in not moving for days) when it downloaded about 1% of data. Also I’ve tried to download other version of the available databases and all having the same issue.

I’ve noticed in the forum there are people mentioning being in Asia Pacific might have a very slow download speed or have problem downloading the database.

I’ve found @aitor.blancomiguez had previously uploaded database to Google Drive and I wonder if there are also alternative download location for the latest database?
Or are there anybody experiencing the same issue? And how can I resolve this?

Lots of thanks.


I’ve been able to download the database this morning but I have a quick question here, as there are .md5 file at the ftp but it’s not seen in my directory, so I wonder do the program help us to do the md5 checksum and proceed with indexing while removing the md5 file if everything is ok?