Error while downloading MetaPhlAn4 database

Hello everyone,

I recently installed MetaPhlAn4 version 4.0.6 (1 Mar 2023) and attempted to run a single fastq sample. As this was my first time running a sample, the program began downloading the marker gene database. Unfortunately, I encountered an error.

The error message is as follows:
‘’’
Downloading http://cmprod1.cibio.unitn.it/biobakery4/metaphlan_databases/mpa_latest
Downloading file of size: 0.00 MB
0.01 MB 25600.00 % 158.30 MB/sec 0 min -0 sec
Downloading MetaPhlAn database
Please note due to the size this might take a few minutes

\Downloading and uncompressing indexes

Downloading http://cmprod1.cibio.unitn.it/biobakery4/metaphlan_databases/bowtie2_indexes/mpa_vOct22_CHOCOPhlAnSGB_202212_bt2.tar
Downloading file of size: 20348.27 MB
12591.62 MB 61.88 % 2.68 MB/sec 48 min 12 sec
Warning: Unable to download http://cmprod1.cibio.unitn.it/biobakery4/metaphlan_databases/bowtie2_indexes/mpa_vOct22_CHOCOPhlAnSGB_202212_bt2.tar

Downloading http://cmprod1.cibio.unitn.it/biobakery4/metaphlan_databases/bowtie2_indexes/mpa_vOct22_CHOCOPhlAnSGB_202212_bt2.md5
Downloading file of size: 0.00 MB
MD5 checksums do not correspond! If this happens again, you should remove the database files and rerun MetaPhlAn so they are re-downloaded
‘’’

I would appreciate any assistance with resolving this issue. Thank you in advance.

Hi @yarinbekor
It seems while download the first files something went wrong. How much space do you have available in your machine?

Hi thank you for the quick response,
About 5.5T

I see, it should be more than enough, I would try to remove the downloaded files and try to install the database again

I tried, but received the same error message. I also tried it from a different machine and got the same error.

I don’t really understand what could be the problem, you could try the download from a different network, I’m really sorry I’m not being able to be more helpful