Downloading MetaPhlAn 4 database

MetaPhlAn version 4.0.4 (17 Jan 2023)

metaphlan --install

After 20%, download process stopped. I tried using screen command, and after two days nothing.

Also, I’ve tried using wget directly from the repository without success.


Hi @diecasfranco
Do you have enough space in your machine for the download? Does the download stop suddenly at 20% or is the download so slow that for reaching 20% it takes days?

Hi @aitor.blancomiguez
I have enough space, look how does it looks

Downloading file of size: 19909.64 MB
7664.99 MB 38.50 % 29.01 MB/sec 7 min 2 sec

No activity since a couple of days. Using htop, the process appear “S”, no local error.

Hi @diecasfranco
Then, I am not sure what is really happening during your download. It does not seem a timeout problem from the cmprod1 server since your download has not been killed. I can only suggest you to try again maybe using a different network

Hi, I had the same issue, I believe it might be due to the server’s firewall rules.

I had to run this from a different network to finish downloading:

wget --continue --limit-rate=20M

I think --limit-rate=20M did the trick (but didn’t work on the same network as I guess I was already blacklisted or something). It caps the download speed at 20MB/s.

Hope that helps.

Hi @simone.pignotti
That was the solution, using wget.

Thank you!