The bioBakery help forum

Prescreen results in no species selected when "-t marker_ab_table"

Hello,

I am currently using the HUMAnN 3 workflow to taxonomically and functionally characterize shotgun metagenomic sequence data derived from human stool samples. During the workflow, I would like MetaPhlAn to output normalized marker counts, but when I use the following command:

humann --input input_data.fastq \
--output output_directory \
--output-basename $FILE_NAME \
--metaphlan-options '-t marker_ab_table --add_viruses' \
--nucleotide-database full_chocophlan.v296_201901 \
--protein-database uniref90_annotated_v201901 \
--prescreen-threshold 0.001 \
--threads 2 \
--verbose

the prescreen step results in no species selected for the custom database. When I change ‘-t marker_ab_table --add_viruses’ to ‘-t rel_ab --add_viruses’ the prescreen works as expected, detecting around 60 species during prescreen. Is there a reason why the prescreen step isn’t picking up species when using ‘-t marker_ab_table’ parameter?

Thank you for any help you can provide!

Best,
Zach

Hi Zach - HUMAnN expects a table in the relative abundance format for picking species to include in the prescreen. If you run MetaPhlAn within HUMAnN with the (default) -t rel_ab option, you can later build a table in the -t marker_ab_table format quickly by re-running MetaPhlAn using the MetaPhlAn bowtie2out intermediate file (saved under HUMAnN’s temp folder) as input instead of the original reads.

You can also flip this process: i.e. run MetaPhlAn outside of HUMAnN using whatever options you’d like, then use the bowtie2out file to build a relative abundance table to pass to HUMAnN via the --taxonomic-profile flag.

Got it, thank you for the tip and quick response!