The bioBakery help forum

HUMAnN3 no species selected from prescreen

Hi everyone,

To start off, I’m pretty new to all of this!

After successfully running through the tutorial, I’m attempting to analyze my own data using HUMAnN3. However, I’ve been getting the message that 0 species are selected from the prescreen and I can’t figure out what’s going on. Here’s the command I used and the output:

humann --input d6.fastq --output Outputs --nucleotide-database ./chocoplan --protein-database ./uniref

image

I’ve tried a lot of troubleshooting on my own (redownloading databases, etc.) but I’m not sure if I’m even on the right track with what’s causing the issue. I’m using a remote server through my workplace so I do not have permissions to change settings like I would normally–I’m not sure if that complicates things. I believe that could be the reason for the bowtie2 error but I’m not sure, although I ran the tutorial fine even with the warning there.

I would really appreciate any guidance on what could be causing this problem. Even getting a general idea of where to start would be very helpful. Thank you!

Welcome! To start with, can you tell us a bit more about your sample? What community it’s from, what kind of sequencing you’re using, etc.?

Thank you! It’s a mouse microbiome study, investigating differences between drug treatments. We did 16S rRNA sequencing using Illumina so we ended up with paired-end reads in fastq format. I concatenated the forward and reverse reads for each sample into one file. After running humann and getting the 0 result, I also tried it on a couple of the original files to see if that would work but I got the same output.

Ah, ok - our community profiling methods (e.g. MetaPhlAn + HUMAnN) are designed for shotgun rather than 16S/amplicon sequencing. You might want to try out a 16S platform like QIIME 2 or mothur instead.