Dear all,

I tried to follow up the tutorial in after installing with conda and tried to plot in graphlan here is what I run: --ifn_tree output/RAxML_bestTree.s__Bacteroides_caccae.StrainPhlAn3.tre.metadata --colorized_metadata subjectID

I got an error of :
Traceback (most recent call last):

  • File “/home/ubelix/dbmr/terziev/anaconda2/bin/”, line 176, in *
  • main(args)*
  • File “/home/ubelix/dbmr/terziev/anaconda2/bin/”, line 103, in main*
  • nodestr = node.get_node_str().strip("’")*
    AttributeError: ‘Node’ object has no attribute ‘get_node_str’

I am not so sure what is wrong and honestly I can run the exact command as in tutorial which is -t output/RAxML_bestTree.s__Bacteroides_caccae.StrainPhlAn3.tre.metadata -m subjectID

It doesn’t accept -t and -m options. So weird!
Anyone can guide me what’s happening?
Thank you so much.
Best wishes,

1 Like

I am having the same issue. I’ve installed graphlan into a conda environment running python 2.7 and then metaphlan into the same environment.

This error pops up when I try to run the commands from the tutorial: --ifn_tree RAxML_bestTree.s__Eubacterium_rectale.StrainPhlAn3.tre.metadata --colorized_metadata Country --leaf_marker_size 60 --legend_marker_size 60