The bioBakery help forum

Export2graphlan: Traceback

Hello,

I am currently running throuh the Metaphlan3 wiki tutorial (https://github.com/biobakery/biobakery/wiki/metaphlan3) with the example data as well as own data. When it comes to creating Graphlan input files with export2graphlan.py I receive tracebacks:

I get this kind of traceback no matter which data I use. When I only install Graphlan and Metaphlan3, the command export2graphlan.py can not be found. Therefore I searched and found the export2graphlan package in bioconda. Running export2graphlan in an environment where the respective package is installed I am getting the traceback shown above.
I use Ubuntu 20.04 and installed each tool in an own environment using conda. I also tried installing different packages in one environment (e. g. Metaphlan and Graphlan, Metaphlan and Graphlan and export2graphlan) but I can not solve the traceback.

Best,
Philipp

Does anyone have a solution for this?

Maybe @fbeghini? :slight_smile:

Hi Philipp,
I can not reproduce the error you get, can you share with me the input files, the command line, and the result of conda list?

Edit: It seems that you are using Python 3 instead of Python2.7, which is required by export2graphlan

Hey Francesco,

thanks a lot, now it works. I do not know what failed. I just repeated the command and now I get the cladogram.