Error when installing GraPhlAn


I created an enviroment and installed metaphlan in that environment. Metaphlan works fine. But when I tried installing GraPhlAn, it fails with the following error.


conda install -c biobakery graphlan


Collecting package metadata (repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: /
Found conflicts! Looking for incompatible packages. failed

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:


  • graphlan -> python[version=‘2.7.*|<3|>=2.7,<2.8.0a0’]

Your python: python=3.7

If python is on the left-most side of the chain, that’s the version you’ve asked for.
When python appears to the right, that indicates that the thing on the left is somehow
not available for the python version you are constrained to. Note that conda will not
change your python version to a different minor version unless you explicitly specify

I get the same error when I tried with python 2.7. Indeed, when I check python version it says 2.7 but after I run command to install graphlan, it gives the above error. Later, when I check python version it says 3.8. Does it automatically updates python or what? I am confused.

Have you tried creating a new clean separate environment and installing GraPhlAn inside it?

Thank you for your help. I was trying to install graphlan in the same environment as metaphlan but it was giving me the above error. As you suggested, I created a new/clean environment, that solved this issue.

Thanks a lot.