Metaphlan4 and the new version humann

I am greatful for noticing the metaphlan4 was updated!

So can metaphlan4 can accept the results from metaphlan3? And when the new HUMAnN version will update, If I run some samples by Metaphlan4, the downstream analysis can analysis by Humann3 or waitting for the new version HumanN4 or etc.

Thx!

Hi @wusan1234
While MetaPhlAn 4 is still compatible with version 3 using the --mpa3 parameter together with the specification of the mpa3 DB with the --index parameter, by default it includes a new database spanning 26,970 species-level genome bins (SGBs, Segata Lab - Computational Metagenomics) with 4,992 of them taxonomically unidentified at the species level (uSGBs).
The results of the new metaphlan 4 database are not compatible with humann3, but we are expecting to release pretty soon the new humann3.5 version that includes compatibility with the new database

thx for ur answer!

hmmm, I noticed the tutorial about metaphlan4 showed we can install it via conda. I tried but only 3.1.0 was the newest version and the marker ref were v31_2019, not vJan_202103, so how can i install the new version, only by clone from github?

thx!

We had some delay having the package available at conda but now the 4.0.0 should be already available: Metaphlan :: Anaconda.org

Hi @aitor.blancomiguez -

  1. I am not sure about what do you mean by “–index” parameter. Can you please explain what this parameter denotes?

2.Can we use database mpa_v30_CHOCOPhlAn_201901 with MetaPhlAn 4 using --mpa3 flag? If yes, how the command should look like in that case?

Many thanks

Hi @DEEPCHANDA7
The --index parameter is used in metaphlan to specify a specific version of the database you want to run. If not specified, MetaPhlAn will look for the latest version available.
So, for running MetaPhlAn 4 with the v30 database, you will have to use the following additional parameters:
--mpa3 --index mpa_v30_CHOCOPhlAn_201901 --bowtie2db v30_db_dir
Being v30_db_dir the directory containing the v30 database.

1 Like