MD5 not matching

[chb4004@curie ~]$ micromamba activate humann3
(humann3) [chb4004@curie ~]$ humann --version
humann v3.8
(humann3) [chb4004@curie ~]$ metaphlan --version
MetaPhlAn version 4.0.3 (24 Oct 2022)

It started with conda install and still continues even when am using mamba.
I have tried changing MetaPhlAn versions (4.0.6, 3.-series) as well as trying to install the new database but the same error persists.

Error message returned from metaphlan :

Downloading MetaPhlAn database

Please note due to the size this might take a few minutes

File /pbtech_mounts/homes051/chb4004/micromamba/envs/humann3/lib/python3.9/site-packages/metaphlan/metaphlan_databases/mpa_vOct22_CHOCOPhlAnSGB_202212.tar already present!

File /pbtech_mounts/homes051/chb4004/micromamba/envs/humann3/lib/python3.9/site-packages/metaphlan/metaphlan_databases/mpa_vOct22_CHOCOPhlAnSGB_202212.md5 already present!

MD5 checksums do not correspond! If this happens again, you should remove the database files and rerun MetaPhlAn so they are re-downloaded

This appears to be the same issue discussed here