Closed I keep getting "MD5 checksums do not correspond!...." error

I am pretty sure there are other people who got this error. The error tells me to remove the database and re-download which I do but I couldn’t manage to make it work. I saw a comment about this, which tells me to re-install Metaphlan by using pip command but it didn’t work either. I don’t think it’s because of a syntax error. What should I do?

Hi @aclydlg
You can try to download the database manually from here: Index of /biobakery4/metaphlan_databases

I did it and I had the error “md5sum: WARNING: 1 computed checksum did NOT match”, what should I do? I still get error from the files

I am having the same issue and unfortunately this is not a technical issue, of by itself we can handle. So, please immediate help. Probably it is easy to solve by developers.
Thank you very much.

I solved it in a very funny way. Download the database manually like “wget (link of .tar)” (under the directory of your metaphlan databases) and you have the chance to download a proper file. Usually it’s tar file that is corrupted. If the luck is on your side and your internet connection is great, the file will be downloaded in a right way. --install doesn’t download it in a proper way. Before running any analyses, check them with the command (md5sum -c (name of the md5 file and the tar file)). If there aren’t any errors, the files are fine you are good to go further.

Hi Açelya,
Thank you for your message. Indeed, neither way worked to download.
You are right, it corrupts after a while download starts :cry:

update: looks working.
“wget (link of .tar)” thing worked and downloaded successfully :slight_smile: