LEfSe issues and errors

Hi. I have been using LEfSe in the past and was successfully able to run the full pipeline with the Galaxy LEfSe tool. Now when I am trying to run the pipeline using new tabular files (I believe to be formatted correctly) and even old ones that successfully worked in the past I run into two errors:

Step A) Info

ERROR:galaxy.datatypes.data:Unable to count lines in file /export/galaxy-central/database/files/004/dataset_4265.dat

Step B) Error message:
Number of significantly discriminative features: 36 ( 36 ) before internal wilcoxon
Traceback (most recent call last):
File “/galaxy_venv/bin/lefse_run.py”, line 33, in
sys.exit(load_entry_point(‘lefse==1.1.2’, ‘console_scripts’, 'lefse_ru

I have tried to resolve these problems many different ways, but find myself very stuck. If anyone has any reconditions. It is greatly appreciated.

I was on the galaxy.org forum. Here is background to the issue. Data import LEfSe error: Cannot count lines in file - lefse - Galaxy Community Help



I am having exactly the same issues, both with new datasets and with the old ones that were previously working.

1 Like

Me too, show error as " galaxy.datatypes.data: Unable to count lines in file /export/galaxy-central/database/files/004/…"

1 Like


Did you guys resolved this issue?

I am affraid I have the same problem.


Hi @garretta @LiaOb21 @rogasan @Peter_Janampa ,

Apologies that you are running into issues. This week was the yearly maintenance on our servers and it has affected our Galaxy site, we are working on resolving this issue ASAP. Our software folks will let you know when we have fixed this bug.

Alternatively, you can use MaAsLin 2, a newer tool of ours, to do a similar analysis to LEfSe if you need to run something quickly.



Hi, @Kelsey_Thompson

Thank you for your information.
Do you have rough estimate when it will be solved?

Hello, I use galaxy online version found updated, the old version of the historical data is missing, when I want to re-analyze, in the ’ format data ’ step is always wrong :
ERROR : galaxy.datatypes.data : Unable to count lines in file / export / galaxy-central / database / files / 017 / dataset _ 17651.dat,
could you tell me what the reason is ?

Dear Kelsey

Thank you for the information. I will revise MaAsLin 2.



I have the same problem in Galaxy, when will you could fix this bug?
"Traceback (most recent call last):
File “/galaxy_venv/bin/lefse_format_input.py”, line 33, in
sys.exit(load_entry_point(‘lefse==1.1.2’, ‘console_scripts’, ‘lefse_format_input.py’)())
File “/galaxy_venv/lib/python3.7/site-packages/lefse/lefse_format_input.py”, line 443, in format_input
feats = numerical_values(feats,params[‘norm_v’])
File “/galaxy_venv/lib/python3.7/site-packages/lefse/lefse_format_input.py”, line 192, in numerical_values
feats[k] = [float(val) for val in v]
File “/galaxy_venv/lib/python3.7/site-packages/lefse/lefse_format_input.py”, line 192, in
feats[k] = [float(val) for val in v]
ValueError: could not convert string to float: ‘ear’ "

I don’t know how to work with R. I’ve seen the tutorial, but it seems complicated.

Hi Kelsey,

Just wondering if there’s a timeline for when LEfSe will be up and running again? I’m trying to use MaAsLin 2 instead but I’m also getting errors when I import my tables… I see a new maintenance notice so I’m assuming it’s due to this?

Thank you,


1 Like

Hi @leahdaloisio

We were doing maintenance on the galaxy servers but they should be running now. Let us know if this has fixed the issue.


no. The mistake is like this.
“ERROR:galaxy.datatypes.data:Unable to count lines in file /export/galaxy-central/database/files/029/dataset_29275.dat”

I don’t know why there are so many options for class. And there is a hash key # in front of bodysite, which is not exsited before

Hello @wc1 ,
It looks like there are some formatting errors in your input file. Can you upload the lefse input file in the thread here and we can test it out and let you know.


Merge goupe 4.txt (164.2 KB)
Thank you for your reply! here is the file


To follow-up on my previous question. I still get the error: ERROR:galaxy.datatypes.data:Unable to count lines in file /export/galaxy-central/database/files/004/dataset_4265.dat

But I am able to complete all the steps in the workflow even with this error.
I am curious if this can just be ignored then?

For me, it is the same problem. Although there is mistake about counting lines, I could process the following steps.

Hi @wc1,

Thank you for providing the file. I could replicate the error on my end as well. The format_data_for_lefse step1 is generating binary file for which galaxy is unable to count the files for. However, this will not interfere with the other steps for lefse visualizations. Please let me know if this is not the case.


Hi @garretta ,
Yes, confirmed that the error message can be ignored for now since all the steps are working fine. We will work on fixing the Unable to count lines in file error asap.
Please let us know if any other issues.