Lefse installation

What is the best way to install? I have been trying since months but I need to get all the tools (from biobakery) installed and most of them are not straightforward. The galaxy is not accessible. I am at my wits end. This is the error i get.

LibMambaUnsatisfiableError: Encountered problems while solving:

  • package lefse-1.0.7-1 requires python <3, but none of the providers can be installed

Could not solve for environment specs
The following packages are incompatible
├─ lefse is installable with the potential options
│ ├─ lefse 1.0.7 would require
│ │ └─ python <3 , which can be installed;
│ └─ lefse [1.0.7|1.0.7.post1|1.0.8.post1] would require
│ └─ python [2.7* |>=2.7,<2.8.0a0 ], which can be installed;
└─ pin-1 is not installable because it requires
└─ python 3.12.* , which conflicts with any installable versions previously reported.

This basically means Lefse is not update to the current version of python but needs a dependecy that is compatible with the latest version of python. Is there a work around for this?

Hi @Shwetha_Kumar ,

We no longer actively support this package and recommend the use of MaAsLin for similar analysis but if you want to use LEfSe you can check if the lefse package will work for your needs which is being developed by the Waldron lab. Additionally we are working on a wrapper to get similar figures as what is produced by LEfSe from MaAsLin.


Thank you, I use Maaslin but currently trying to replicate published results. I see so many authors showing results from Lefse but can’t seem to even install it. I will probably move on to the r wrapper.