Humann3/metaphlan 3.0 error md5 checksums do not match

Can you post the output of conda list from the activated metaphlan-3.0 environment?

Thank you for responding! Here is the output of “conda list”

(metaphlan-3.0) curangalt-osx:humann3 curanga$ conda list

packages in environment at /Users/curanga/opt/anaconda3/envs/metaphlan-3.0:

It looks like that python is not even installed, have you run conda install python=3.7?

(metaphlan-3.0) curangalt-osx:humann3 curanga$ conda install python=3.7

Collecting package metadata (current_repodata.json): done

Solving environment: done

All requested packages already installed.

(metaphlan-3.0) curangalt-osx:humann3 curanga$

This is strange, no packages are installed in the environment, but still conda install says that python3.7 is installed.
Can you post here the output of conda info?

Hi thank you for your patience! I installed that huge package Anaconda Navigator, if there is a better way of installing python please let me know. Here is the output for condo info:

(metaphlan-3.0) curangalt-osx:humann3 curanga$ conda info

active environment : metaphlan-3.0

active env location : /Users/curanga/opt/anaconda3/envs/metaphlan-3.0

shell level : 2

user config file : /Users/curanga/.condarc

populated config files :

conda version : 4.8.3

conda-build version : 3.18.11

python version : 3.7.6.final.0

virtual packages : __osx=10.13.6

base environment : /Users/curanga/opt/anaconda3 (writable)

channel URLs : https://repo.anaconda.com/pkgs/main/osx-64

https://repo.anaconda.com/pkgs/main/noarch

https://repo.anaconda.com/pkgs/r/osx-64

https://repo.anaconda.com/pkgs/r/noarch

package cache : /Users/curanga/opt/anaconda3/pkgs

/Users/curanga/.conda/pkgs

envs directories : /Users/curanga/opt/anaconda3/envs

/Users/curanga/.conda/envs

platform : osx-64

user-agent : conda/4.8.3 requests/2.22.0 CPython/3.7.6 Darwin/17.7.0 OSX/10.13.6

UID:GID : 3737:63

netrc file : None

offline mode : False

(metaphlan-3.0) curangalt-osx:humann3 curanga$

Conda is not configured correctly to fetch packages from bioconda and conda forge. You should run the following commands in the exact order:

conda config --add channels defaults
conda config --add channels bioconda
conda config --add channels conda-forge

Then, try again from the activated metaphlan-3.0 environment to install again python 3.7 and metaphlan

conda install python=3.7
conda install metaphlan

Check with conda list | grep metaphlan if the installed build (3rd column) is pyh5ca1d4c_4. If not, try to run conda update metaphlan

Ok, almost there! Thank you so much for helping me get this far… Now it is an issue with Bowtie2. Please be aware that I had to install humann with “pip install --no-binary :all:” because conda didn’t work. So how do I include Bowtie2?

Best,

Carla

(metaphlan3.0) curangalt-osx:humann3 curanga$ conda list|grep metaphlan

packages in environment at /Users/curanga/opt/anaconda3/envs/metaphlan3.0:

metaphlan 3.0 pyh5ca1d4c_4 bioconda

(metaphlan3.0) curangalt-osx:humann3 curanga$ humann --version

humann v3.0.0.alpha.2

(metaphlan3.0) curangalt-osx:humann3 curanga$ humann --input demo.fastq --output demo_fastq

Output files will be written to: /Users/curanga/Desktop/humann3/demo_fastq

CRITICAL ERROR: Can not call software version for bowtie2

(metaphlan3.0) curangalt-osx:humann3 curanga$

I have bowtie2 installed, but the vall using --version is odd.

(metaphlan3.0) curangalt-osx:humann3 curanga$ bowtie2 --version

/Users/curanga/opt/anaconda3/envs/metaphlan3.0/bin/bowtie2-align-s version

64-bit

Built on

Sat Jun 6 20:43:32 UTC 2020

Compiler: InstalledDir: /Users/distiller/project/miniconda/conda-bld/bowtie2_1591476031995/_build_env/bin

Options: -O3 -msse2 -funroll-loops -g3 -march=core2 -mtune=haswell -mssse3 -ftree-vectorize -fPIC -fPIE -fstack-protector-strong -O2 -pipe -stdlib=libc++ -fvisibility-inlines-hidden -std=c++14 -fmessage-length=0 -isystem /Users/curanga/opt/anaconda3/envs/metaphlan3.0/include -fdebug-prefix-map=/Users/distiller/project/miniconda/conda-bld/bowtie2_1591476031995/work=/usr/local/src/conda/bowtie2-2.4.1 -fdebug-prefix-map=/Users/curanga/opt/anaconda3/envs/metaphlan3.0=/usr/local/src/conda-prefix -DPOPCNT_CAPABILITY -DWITH_TBB -std=c++11 -DNO_SPINLOCK -DWITH_QUEUELOCK=1

Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}

Here is the conda list call:

(metaphlan3.0) curangalt-osx:humann3 curanga$ conda list | grep bowtie2

bowtie2 2.4.1 py37h8d6d27b_2 bioconda

Best,

Carla

You can install it using conda but you need to specify the version
conda install bowtie2=2.3.5.1

2.4.1 has the version reporting function broken

Fantastic thank you this worked. However, I am trying to use humann3 for peptide identification. However, I think my fasta file is parsed incorrectly:

1
LLLARKLKLNLLLLLVLAAK
2
DEARRRMRRWWNARHNHPRRRLWVSRMPR
3
HDMCKWGEWWYQYLPTAYYDCMMAK
4
VKLLKKKKKGAKLLVSVCK

Do you have a required fasta format that is required? I would greatly appreciate knowing what this is!

Best,

Carla

#CPU threads: 1

Scoring parameters: (Matrix=BLOSUM62 Lambda=0.267 K=0.041 Penalties=11/1)

Temporary directory: /Users/curanga/Desktop/humann3/C1peps/C1novor_humann_temp/tmp4bngxi3p

Opening the database… [0s]

Percentage range of top alignment score to report hits: 1

Reference = /Users/curanga/opt/anaconda3/envs/metaphlan3.0/lib/python3.7/site-packages/humann/data/uniref_DEMO/uniref90_demo_prots_v201901.dmnd

Sequences = 44

Letters = 18842

Block size = 2000000000

Opening the input file… [0.001s]

Opening the output file… [0s]

Loading query sequences… [0s]

Error: Error reading input stream at line 2: Invalid character (L) in sequence

HUMAnN assumes you’re starting from nucleotide sequences, hence that first L is raising an eyebrow. You could try just directly searching your peptides against the UniRef90 database using diamond in blastp mode (i.e. protein-to-protein).

Yes, I have been doing this as well and have an m8 file I have been working on, but for some reason I get this error. Do you all offer a detailed manual for humann3 by chance? There seems to be a lot to it! Thank you so much for helping with this.

(metaphlan3.0) curangalt-osx:humann3 curanga$ humann --input C1uniref.m8 --input-format blastm8 --output C1peps
Output files will be written to: /Users/curanga/Desktop/humann3/C1peps

Process the blastm8 mapping results …
Traceback (most recent call last):
File “/Users/curanga/opt/anaconda3/envs/metaphlan3.0/bin/humann”, line 33, in
sys.exit(load_entry_point(‘humann==3.0.0a2’, ‘console_scripts’, ‘humann’)())
File “/Users/curanga/opt/anaconda3/envs/metaphlan3.0/lib/python3.7/site-packages/humann/humann.py”, line 1074, in main
unaligned_reads_store, args.input, alignments)
File “/Users/curanga/opt/anaconda3/envs/metaphlan3.0/lib/python3.7/site-packages/humann/search/translated.py”, line 293, in unaligned_reads
identity_threshold = config.identity_threshold)
File “/Users/curanga/opt/anaconda3/envs/metaphlan3.0/lib/python3.7/site-packages/humann/search/blastx_coverage.py”, line 40, in blastx_coverage
for alignment_info in utilities.get_filtered_translated_alignments(blast6out, alignments, apply_filter=apply_filter, log_filter = log_messages, query_coverage_threshold = query_coverage_threshold, identity_threshold = identity_threshold):
File “/Users/curanga/opt/anaconda3/envs/metaphlan3.0/lib/python3.7/site-packages/humann/utilities.py”, line 1308, in get_filtered_translated_alignments
identity=alignment_info[config.blast_identity_index]
IndexError: list index out of range
(metaphlan3.0) curangalt-osx:humann3 curanga$

You can find the user manual on the GitHub repository here (https://github.com/biobakery/humann) and an extensive tutorial on the bioBakery wiki here (https://github.com/biobakery/biobakery/wiki/humann3)

It seems i meet the same question as in this question. i have operated as you suggest but when i run conda list | grep metaphlan

(metaphlan-3.0) wangzhenyu@wangzhenyudeMacBook-Pro metaphlan_database % conda list | grep metaphlan

packages in environment at /Users/wangzhenyu/opt/miniconda3/envs/metaphlan-3.0:

metaphlan 3.0 pyh5ca1d4c_1 bioconda

It seems like metaphlan is not updated, how could i solve this problem?
thank you!

Can you post the list of the installed packages in the metaphlan-3.0 environment? Have you configured correctly the conda channels?

Just jumping onto this topic; I’m having similar problems running the metaphlan3 in a newly made python environment. I ran metaphlan --install and got the same md5 error as above.

Should I repost this as a different topic?

Below are the installed packages:

bcbio-gff 0.6.6
biom-format 2.1.8
biopython 1.77
certifi 2020.6.20
chardet 3.0.4
click 7.1.2
CMSeq 1.0.1
cycler 0.10.0
Cython 0.29.21
DendroPy 4.4.0
future 0.17.1
h5py 2.10.0
idna 2.10
kiwisolver 1.2.0
matplotlib 3.2.1
MetaPhlAn 3.0.1
numpy 1.19.1
pandas 1.0.5
PhyloPhlAn 3.0.0
pip 20.2.1
pyparsing 2.4.7
pysam 0.15.4
python-dateutil 2.8.1
pytz 2020.1
requests 2.24.0
scipy 1.4.1
seaborn 0.10.1
setuptools 49.3.1
six 1.15.0
urllib3 1.25.10
wheel 0.34.2

Thanks so much for any feed back.

The setup seems OK. Have you tried to manually remove the tar and md5 files and run again the installation?

Thanks for the feedback! Did just that and it progressed further, but resulted in a different error. Output pasted below:

(MetaphlanHumann_env) [krey@cedar5 metaphlan_databases]$ metaphlan --install

Downloading MetaPhlAn database
Please note due to the size this might take a few minutes

File /home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/metaphlan_databases/file_list.txt already present!

Downloading https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AADlxibskzbPHPoDl6S-FyKka/mpa_v30_CHOCOPhlAn_201901.tar?dl=1
Downloading file of size: 366.62 MB
366.62 MB 100.00 % 1.80 MB/sec 0 min -0 sec
Downloading https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AACTzoUYDqZps8u2JqWCNCODa/mpa_v30_CHOCOPhlAn_201901.md5?dl=1
Downloading file of size: 0.00 MB
0.01 MB 12800.00 % 5.84 MB/sec 0 min -0 sec

Decompressing /home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/metaphlan_databases/mpa_v30_CHOCOPhlAn_201901.fna.bz2 into /home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/metaphlan_databases/mpa_v30_CHOCOPhlAn_201901.fna
Traceback (most recent call last):
File “/home/krey/MetaphlanHumann_env/bin/metaphlan”, line 8, in
sys.exit(main())
File “/home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/metaphlan.py”, line 916, in main
pars[‘index’] = check_and_install_database(pars[‘index’], pars[‘bowtie2db’], pars[‘bowtie2_build’], pars[‘nproc’], pars[‘force_download’])
File “/home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/init.py”, line 290, in check_and_install_database
download_unpack_tar(FILE_LIST, index, bowtie2_db, bowtie2_build, nproc)
File “/home/krey/MetaphlanHumann_env/lib/python3.8/site-packages/metaphlan/init.py”, line 181, in download_unpack_tar
bt2_build_output = subp.check_output([bowtie2_build, ‘–usage’], stderr=subp.STDOUT)
File “/cvmfs/soft.computecanada.ca/easybuild/software/2017/Core/python/3.8.2/lib/python3.8/subprocess.py”, line 411, in check_output
return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
File “/cvmfs/soft.computecanada.ca/easybuild/software/2017/Core/python/3.8.2/lib/python3.8/subprocess.py”, line 489, in run
with Popen(*popenargs, **kwargs) as process:
File “/cvmfs/soft.computecanada.ca/easybuild/software/2017/Core/python/3.8.2/lib/python3.8/subprocess.py”, line 854, in init
self._execute_child(args, executable, preexec_fn, close_fds,
File “/cvmfs/soft.computecanada.ca/easybuild/software/2017/Core/python/3.8.2/lib/python3.8/subprocess.py”, line 1702, in _execute_child
raise child_exception_type(errno_num, err_msg, err_filename)
FileNotFoundError: [Errno 2] No such file or directory: ‘bowtie2-build’

Sorry for the delayed reply; removing the files and running the installation again fixed the issue. On my setup for this software, I had to update my version of glpk to get everything to work but once I did so Humann3 ran without issue.