Getting HUMAnN2 and MetaPhlAn2 to run together

Hi, I’m trying to get functional profiles for my microbiome dataset using HUMAnN2.

I installed MetaPhlAn2 v2.9 and HUMAnN2 v2.8.1 but ran into this issue:

ERROR: The MetaPhlAn2 taxonomic profile was generated with the CHOCOPhlAn_201901 database. HUMANn2 is not yet compatible with this database. Please run with the legacy MetaPhlAn2 database. Also keep an eye out for HUMAnN2 v2.9 which will be compatible with the latest MetaPhlAn2 v2.9 database.

I tried installing MetaPhlAn2 v2.6, however when I tried using the example data, I got this error:

No MetaPhlAn BowTie2 database found [–bowtie2db option]! (or wrong path provided).

Expecting location ${mpa_dir}/db_v20/map_v20_m200


I checked the bin directory and there was no directory call “db_v20”. Is there anyway I can download the bowtie indices myself? I noticed with MetaPhlAn2 v2.9, the bowtie indices were generated automatically but they weren’t with MetaPhlAn v2.6.

Ultimately, I just want to be able to use HUMAnN2. Is there any other way I can get HUMAnN2 and MetaPhlAn2 to work together?

Thank you!

Sorry for the delay. You’re correct that HUMAnN 2.8.1 requires a version of MetaPhlAn <2.9. However, other recent versions of MetaPhlAn (<2.9) should build their marker databases automatically. It’s possible that by uninstalling the software, removing the MetaPhlAn databases, and re-installing that everything will get hooked up correctly.

Alternatively, you can find all versions of the marker databases here for manual download (you would want the v20 versions for use with HUMAnN 2.8.1):


have you got this sorted out per franzosa’s suggestion? I’m running into a similar situation . Your update will be very helpful. thank you in advance!


Thank for the info @franzosa! @JQL, I ended up uninstalling MetaPhlAn and HUMAnN2 and reinstalled HUMAnN2 with

conda install -c biobakery humann2

That way, it install HUMAnN2 with the correct version of MetaPhlAn (and all the other dependencies).

1 Like

thank you for your quickly reply.

Hi @azhang2 !!!
which version of humann2 and metaphlan does this command installs?

I think it installs metaphlan2 v2.7.7 and humann2 v2.8.1

1 Like