No MetaPhlAn BowTie2 database found

I’ve seen so many forum questions about this, and I’ve tried so many different things, but I’m running out of ideas. No matter what I do, MetaPhlAn will not acknowledge it’s own database.

I’m running HUMAnN v3.6 and MetaPhlAn 4.0.2 in conda. I have the mpa_vJan21_CHOCOPhlAnSGB_202103 database install, both in the conda environment with HUMAnN (home/anaconda3/envs/HUMAnN_3.6/lib/python3.10/site-packages/metaphlan/metaphlan_databases) and in an external directory (home/GeneticData/ProgrammeFiles/biobakery/databases/bowtie2db). I have provided MetaPhlAn with the ‘–bowtie2db -x’ options to both the internal and external database locations, I’ve run ‘metaphlan --install’ and get the output ‘the databases are installed’.

I have even tried uninstalling and reinstalling HUMAnN to check if something went wrong with the installation the first time. Upon running ‘humann_test --run-functional-tests-tools --run-functional-tests-end-to-end’, I still get the error message
‘Error message returned from metaphlan :
No MetaPhlAn BowTie2 database found (–index option)!
Expecting location bowtie2db’

What else can I do?

1 Like

Hi @figbeirns
Is this problem happening when running metaphlan alone or within humann 3.6?

This was happening when I was running metaphlan via humann. My solution in the end was to download the bowtie2db into a separate directory and literally copy the files over to metaphlan’s default bowtie2db. Once I did that, I stopping receiving the error messages