How to install Metaphlan2 legacy database


i hope you can help me.
I just installed MetaPhlAn2 and HUMAnN2 with conda in an virtual environment. This means i have now MetaPhlAn2 V2.96 and HUMAnN2 V2.8.1. Starting humann2 on a metagnome fastq file i run into this error:
ERROR: The MetaPhlAn2 taxonomic profile was generated with the CHOCOPhlAn_201901 database. HUMANn2 is not yet compatible with this database. Please run with the legacy MetaPhlAn2 database. Also keep an eye out for HUMAnN2 v2.9 which will be compatible with the latest MetaPhlAn2

how and where do i get the legacy database, or do i need to downgrade to an older version of MetaPhlAn2? I couldn’t find any information on how to fix this

Thank you and best wishes

Hello Sonja, If you downgrade to an older version of metaphlan v2 it will also install an older database. With this install change you should then be able to run humann v2.8.1.

Thank you,

Hi! I’m a bit new to this and was wondering where exactly I can find an older version of metaphlan2 with the right databases. Will an old release from github be sufficient? Thank you so much!


i installed an older Version with conda: you can list available Version with conda search metaphlan2 and install it with conda install metaphlan2=2.7.7 for example
Not sure if is the best solution, but worked for me.

best wishes

You can also use the -x flag to specify a database version, and if it’s available online MetaPhlAn will download and format it for you.

I’m struggling with this error also.
I used database “chocophlan.tar.gz” that downloaded from

i use Humann2 version 2.8.2
below is more information from log file
nucleotide database folder = $chocophlan
protein database folder = $uniref
pathways database file 1 = $metacyc_reactions_level4ec_only.uniref.bz2
pathways database file 2 = $metacyc_pathways_structured_filtered
utility mapping database folder = $utility_mapping

Thank you in advance for your help