CRITICAL ERROR: The executable not found

Hi all,

I am trying to run humann2 and get this error:

(primate) root@DESKTOP-J59VIIJ:/mnt/c/Users/samde/gutmicrobiome# humann2 --input primateFastq/kneadpaired/KIT_HANDLER_DN_MG3_D8.filt1_kneaddata_paired_1.fastq --output humOut/KIT_HANDLER_DN_MG3_D8.filt1_kneaddata_paired_1 --threads 3
Output files will be written to: /mnt/c/Users/samde/gutmicrobiome/humOut/KIT_HANDLER_DN_MG3_D8.filt1_kneaddata_paired_1
CRITICAL ERROR: The executable can not be found. Please check the install.

There is a similar post saying to run --version But I just get command not found. I tried installing metaphlan2 and get a “biom-format” error:

  error: command 'gcc' failed: No such file or directory: 'gcc'

[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
ERROR: Failed building wheel for biom-format
Failed to build biom-format
ERROR: Could not build wheels for biom-format, which is required to install pyproject.toml-based projects

And then I cannot install biom-format etiher… Have spent all day on this but no luck… Any ideas?? For context I am on a WSL system with Ubunutu downloaded. And currently in a conda environment where only pip installs have worked. Conda installs keep finding inconsistencies.

1 Like