The bioBakery help forum

Unknown bowtie2 errors

I have tried kneaddata 0.6.1 and 0.7.4 with no luck running bowtie2.

If I try running bowtie2 on its own I get: perl: symbol lookup error: /usr/lib64/perl5/auto/Fcntl/Fcntl.so: undefined symbol: Perl_xs_apiversion_bootcheck

If I try running kneaddata, the bowtie2 step gives: Error message returned from bowtie2 :
/dfs/IB/Weis_Lab/kochja/opt/conda/envs/kneaddata/bin/bowtie2-align-s: symbol lookup error: /dfs/IB/Weis_Lab/kochja/opt/conda/envs/kneaddata/bin/bowtie2-align-s: undefined symbol: _ZN3tbb10interface78internal15task_arena_base19internal_initializeEv
(ERR): Description of arguments failed!

I have tried installing different versions of tbb based on this post: Conda version does not work with most recent tbb version · Issue #336 · BenLangmead/bowtie2 · GitHub

I have tried installing older versions of bowtie2 as well.

Thoughts?

Thanks!

I dont’ know if you were able to fix this issue but I think I stumbled upon an answer HERE.

PERL5LIB=""; humann -i demo.fastq -o demo_out