The bioBakery help forum

Unable to format data for LEfSe

I have tried reformatting my text file a dozen different ways and cannot figure out what is wrong with it. I keep getting this error:

Traceback (most recent call last):
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 435, in
feats = numerical_values(feats,params[‘norm_v’])
File "/shed_tools/testtoolshed

anyone know what I am doing wrong? I thought it may have been special characters but I have done find and replace for everything I can think of and looked at every single data entry point and they’re all just regular numbers.

Hello,
I’m not sure what might be causing the error, but I’m happy to investigate. Is there a datafile you could send me that reproduces the error?
Thanks,
Meg

Thank you so much for the offer!

I think my problem was an extra row of metadata. I have 3 factors and this can only handle 2, so I had to delete one row containing the 3rd factor to be able to use this and then it worked!

Good to hear!
Best,
Meg