The bioBakery help forum

Error on Format Data for LEfSe

Hello,
I am having a current error message:

Traceback (most recent call last):
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 435, in
feats = numerical_values(feats,params[‘norm_v’])
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/format_input.py”, line 174, in numerical_values
feats[k] = [float(val) for val in v]
ValueError: could not convert string to float: A2_5_d_1

The error message sent has been the same for several tables of my dataset. It is always in the same lines (435 and 174) and there is nothing unusual in these lines compared with the others. Also, regarding the value error in the sample A2_5_d_1 is recurrent for other days analysed. When only samples of group B are analysed the error is on sample B2_5. I have asked to other colleagues to run my tables on the same website and in their computer is currently running without any problem.
I am running the analysis on Chrome, but I also tested on Firefox and the error is the same.
Do you have any insight of what problem can it be?
Thank you in advance for your help.
Best,
Cátia

Hi Cátia,
I’m currently looking into this issue, and it looks like someone else on the help forum is experiencing the same problem. Would it be possible to send me a data file that produces the error on your computer?
Thanks,
Meg

Hi Meg,

Many thanks for your reply.
You can find in attach both the excel and the .txt file that I used for the analysis.
I will look forward to hearing from you.

Best,
Cátia

Meg Short via The bioBakery help forum <biobakery@discoursemail.com> escreveu no dia segunda, 25/01/2021 à(s) 17:20:

d-1_gg.txt (109 KB)

(Attachment d-1_gg.xlsx is missing)

Hi Catia,
I’m able to upload and format your data successfully in LEfSe. A few things to check: Are you using the most recently uploaded version of the data? Are you correctly specifying the Class and Subject variables? Did you upload the data in tabular format?
Give those a check and let me know if any of these help.
Best,
Meg

Hi Meg,

Thank you for your suggestions.
Finally, I managed to format the data and run LEfSe! I am using the most recent uploaded version of the data (even create new history) and uploaded the data in tabular format. For the Class and Subject variables, I am pretty sure I have already tried this combination before: Class: #1 Class and Subject: #ASV_id, but for this time worked and is also working for other tables I have to analyse.
Again, many thanks for your help and suggestions!

Have a great day!

Best,
Cátia

Meg Short via The bioBakery help forum <biobakery@discoursemail.com> escreveu no dia segunda, 25/01/2021 à(s) 19:29: