Tree rooting with PhyloPhlan

Hello, I am having some issues.
I am trying to make a phylogenetic tree using roughly 22 different bacterial strains.
A genus of archaebacteria is being used as an outgroup to root my tree.
Unfortunately, the archaebacteria keep getting placed deep inside the tree (close to bacillus).
Moreover, every time a tree is generated, exactly one of the genera ends up with its member species splitting up near the tree root, rather than remaining in a single clade.
For example, say the genus is Ochrobactrum.
The tree would end up with three nodes coming out of the root: one with O. ciceri, one with O. intermedium, and one with the entire rest of the tree (including the remaining Ochrobactrum strains).

Is there some way to force the program to use the archaebacteria as an outgroup?

Hello, so the way outgroups work is to add it/them among your inputs and the re-root the resulting phylogeny w.r.t. it/them.
In your case, if I have understood correctly, you have a genome from archaebacteria that you want to use as an outgroup, so after PhyloPhlAn builds the phylogeny you should open it with a software like Archaeopteryx and set the root of the phylogeny in the branch where the outgroup genome(s) is placed.

As far as I know, there is no way to tell FastTree to use a specific genome(s) as outgroup.
Instead, if you use RAxML ( or IQ-TREE ( there are params to set an outgroup, and if you want to exploit this option you can edit the configuration file and add to it the specific option so PhyloPhlAn can run it.

I hope this helps.

Many thanks,

It worked!

Thank you so much for this!