The bioBakery help forum

Struggling with the input datasets

Hi guys,

Thanks for this very great tool.

I have been trying to upload my dataset and recurrently, I have been getting the following error when trying to run the command:

ccrepe.results <-ccrepe(x = otuY, iterations = 20, min.subj = 10, make.output.table = TRUE)

:

I produced my dataset from a phyloseq object and I have tried many ways to upload it and formatted it following the tutorial, however I always get the “$ operator error”

That’s how my dataset looks like

I have been formatting data sets for a day and a half to the border of paranoia, so any tip will be really appreciate :slight_smile:

Thanks,

Jesus

Hi Jesus (@miguensblanco),

Sorry, you are running into issues! This one is going to be hard to diagnosis without a minimally reproducible example. Are you able to send some data (either through here or via email)? It can be either your real data, a toy example, or a blinded version.

Best,
Kelsey

otuY.csv (17.7 KB)
otuY.txt (62.5 KB)

Hi Kesley,

Thanks for the prompt reply!!

I was not sure if it was allowed to upload my files! I just uploaded one dataset formatted in two different ways, hopefully it makes sense.

The data came from a phyloseq object which after some filters for the taxa abundance was cluster to the genus level using the command tax_glom. Finally I save the otu table as csv file (write.csv) (or as a txt for the second dataset) and then import the dataset back to R as a dataframe.

If it is not enough I am happy to send my script or whatever is needed!

Thanks again,

Jesus

I’m not exactly sure where the issue is coming from, but I was able to get results with the following code.

library(ccrepe)

otuY = read.table("C:/Users/aghazi/Downloads/otuY.csv",
                  sep = ",",
                  header = TRUE)

otuY$X = NULL # Delete the sample IDs

ccrepe(x = otuY, iterations = 20, min.subj = 10, make.output.table = TRUE)

I also tried starting from your .txt file (which didn’t have sample IDs) and was also able to get results.