The bioBakery help forum

Problem with setting environment variable $BIOBAKERY_WORKFLOWS_DATABASES

Hi

I have been trying to install the environment variable BIOBAKERY WORKFLOWS with pip (Installing the workflows with pip · biobakery/biobakery_workflows Wiki · GitHub) and then BIOBAKERY WORKFLOWS DATABASES using $ biobakery_workflows_databases --install --wmgx. After solving for many errors, I have now hit the wall in the form of “setting environment variable $BIOBAKERY_WORKFLOWS_DATABASES”

As suggested in “Installing the workflows with pip” I have installed the workflows in a static environment: install_workflows. However, due to the disk space restrains from the univ management, the databases need to be installed at a custom location (in my case, it is /scratch/users/nus/saxena/miniconda3/envs/biobakery/opt/biobakery_workflows_databases). Now, for that I have set the environment variable by specifying
“export BIOBAKERY_WORKFLOWS_DATABASES=/scratch/users/nus/saxena/miniconda3/envs/biobakery/opt/biobakery_workflows_databases” in .bashrc file. However, I am still getting the error “A custom install location was selected. Please set the environment variable $BIOBAKERY_WORKFLOWS_DATABASES to the install location.”

May I know if there is any specific way of setting the environmental variable?

Requesting your help

Regards
Gourvendu