The bioBakery help forum

Problem with LEfSe first step

Hi,
I’m trying to use the LEfSe interface but I can not open the first step (A - format data for LEfSe). The galaxy gives the following message:
‘Tool request failed’ - Uncaught exception in exposed API method:

I have successfully used it before, but now this message appears and I cannot format my data.

Thanks for helping.

L Mendes

Hi @lwmendes ,

Thank you for reaching out to bioBakery Lab. We just tested LEfSe and it works fine. Can you please try the incognito window to make sure that no old session cookies have been stored?

Also, would you mind attaching your input file please? We can take a look at it.

Regards,
Sagun

Hi @sagunmaharjann

Thank you for the reply. I tried using the incognito window and also using different browsers (Safari and Firefox) and the same message appears. I had no problem in upload my file. The error appears only when I choose the step A (format data - I click in it and the message appears).

I uploaded my file and a print screen of the error.

Thanks,
Lucas

LDA.txt (20.2 KB)

Hi Lucas,
The issue seems to come from one of the characters used, the a with the ~ on top. If you change the label it is able to format the data correctly. It might be something you have to manually add back in later–sorry about that!
Best,
Meg

Hi Meg,
Yes! Probably that.It worked now.
Thank you very much for the help.

Cheers,

Lucas