No results at LEfSe analysis

Dear all,

I am using a LEfSe analysis for my sequencing data. I use this format pasted to .tsv file in the notepad:


Nevertheless, I do not receive any results. I got that there does not have to be any significant difference among taxons, but I have tried a lot of variable values to obtain any result and to confirm that I work correctly and the input file is ok. So I have tried every combination of “Set the strategy for multi-class analysis” and “Do you want the pairwise comparisons among subclasses to be…” at the step B (LDA Effect Size) and after that didn’t do anything, I setup both Alpha values to 1. In my opinion, that means I should see at least some differences. But I do not.

So I would like to ask you if I am performing this analysis correctly and if so, what can be the troubleshoot?

Thank you a lot!


Here is the input file.

Hello Martin,
Even if you set your alpha criterion to 1, LEfSe still filters by LDA effect size. So, if you have very small differences in effect size, they won’t be detected even if the p-value is below the alpha criterion. If you want to make sure it is running correctly, you can try decreasing the LDA threshold and see if results show up.
I hope that helps!

Thank you very much! :slight_smile: