Metaphlan V4.0.2 and Huma 3.6: MetaPhlAn taxonomic profile provided was not generated with the expected database

I am facing the same problem too! Does anybody find a way to solve it? :sob:

1 Like

I’m using humann v3.6.1 and MetaPhlAn version 4.0.6 (1 Mar 2023), but face the same problem.
The MetaPhlAn taxonomic profile provided was not generated with the database version v3 or vJan21 . Please update your version of MetaPhlAn to at least v3.0 or if you are using MetaPhlAn v4 please use the database vJan21.

Important! The MetaPhlAn 4 database has been substantially increased in comparison with the previous 3.1 version. Thus, for running MetaPhlAn 4, a minimum of 15GB or memory is needed.

ANSWER

If you have installed MetaPhlAn using Anaconda, it is advised to install the database in a folder outside the Conda environment. To do this, run

$ metaphlan --install --bowtie2db <database folder>

If you install the database in a different location, remember to run MetaPhlAn using --bowtie2db <database folder>!

By default, the latest MetaPhlAn database is downloaded and built. You can download a specific version with the --indexparameter

$ metaphlan --install --index mpa_vJan21_CHOCOPhlAnSGB_202103 --bowtie2db <database folder>

When --index is specified, MetaPhlAn skips the check for the latest database version and run the analysis using the database version provided by --index located in --bowtie2db.

This option is recommended when MetaPhlAn is run on HPC clusters or containerized

When --index is specified, MetaPhlAn skips the check for the latest database version and run the analysis using the database version provided by --index located in --bowtie2db.

This option is recommended when MetaPhlAn is run on HPC clusters or containerized

If you have issues in downloading the database, you can get it from:

Just download the .tar, .md5, and the mpa_latest files and place them in the metaphlan_databases folder.

source: MetaPhlAn 4 · biobakery/MetaPhlAn Wiki · GitHub

Thank you @PabloGallardoM for your detailed post with the answer!

Hi @Katharina_Kujala, If you roll back your MetaPhlAn database to the vJan21 version it should resolve the error.

Thank you,
Lauren

@Katharina_Kujala Sorry I forgot to mention that upgrading to the latest HUMAnN version will provide a clearer error message.

Thank you,
Lauren

Thanks for the advice. But if I understood it right, I cannot actually use the newest MetaPhlAn DB if I want to run humann?
I actually found that when I just change the first line in the MetaPhlAn output to state an older database version, humann accepts it for some reason. So is there really any other problem with the MetaPhlAn output generated with the newest DB than the first line in the output file?

Thanks,
Katharina

@Katharina_Kujala Great questions! Yes, HUMAnN checks the version line in the MetaPhlAn file to make sure they are compatible. HUMAnN currently is only compatible with the MetaPhlAn vJan21 database and not yet the latest vOct22 database. There is a mapping file in HUMAnN with associations of SGBs to species that is specific to the MetaPhlAn vJan21 database which is why it checks the MetaPhlAn version. We are working on a new HUMAnN release which will be compatible with the latest MetaPhlAn database. We hope to have this ready soon and will post here when released.

Thanks!
Lauren

2 Likes

Hello,
I tried as you said: Humann 3.6.1, Metaphlan 4.0.6 with database vJan21 But it still doesn’t work.

Do I have to add the argument

–metaphlan-options “–bowtie2db $PATHDB”

Thanks for the help

I think you would only need that option if you installed the database in a location other than the default. You would need the --index <version> option though to point to the vJan21 database.

Please post again if you continue to run into issues.

Thank you,
Lauren