Metaphlan 4 database during humann3 run


I have tried metaphlan --install to download the databases, it did not work properly. So I have downloaded them using wget option. the indexes, bt2.tar and bt2.md5 and mpa_vJun23_CHOCOPhlAnSGB_202307.tar and md5 files. I downloaded them outside of miniconda3 to my own folder.

Then, when I ran humann3: this is my code.

path/to/humann --input fastq.gz --protein-database path/to/humann3_databases/uniref --threads 16 --search-mode uniref50 --nucleotide-database path/to/humann3_databases/chocophlan --bowtie2 path/to/miniconda3/bin/ --metaphlan-options “–bowtie2db path/to/metaphlan_databases/” --metaphlan-options “–index path/to/metaphlan_databases/mpa_vJun23_CHOCOPhlAnSGB_202307” --output X_uniref50.trimmed_humann3

it deletes all the md5 and tar files from the database folder. why does it deletes the files from the database folder. Then, I need to redownload them everytime I ran humann with a new input. Do I need to re-download them each time I ran humann? How I can solve this issue?

I’m going to move this over to the MetaPhlAn channel since I don’t think this is something that HUMAnN specifically is doing. I can confirm that you do not need to redownload anything for MetaPhlAn each time you want to run HUMAnN.