The bioBakery help forum

Installation/Dependency Error biobakery_workflows

Dear all,

I hope you are well.
I am struggling with the installation of the biobakery_workflows package

Installed anaconda, created an environment with python v3.7.7

Running
conda install -c biobakery biobakery_workflows

leads to:
UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

Specifications:

    • biobakery_workflows -> python[version=’>=3.8,<3.9.0a0’]*

Your python: python=3.7.7

which leads me to update python to a newer version (v3.8.5);

rerunning the biobakery_workflows package installation it leads to:

UnsatisfiableError: The following specifications were found
to be incompatible with the existing python installation in your environment:

Specifications:

    • biobakery_workflows -> python[version=’>=2.7,<2.8.0a0|>=3.7,<3.8.0a0’]*

Your python: python=3.8

I am a bit confused. What am I missing?

Thanks for your help!

BW,
Annika