The bioBakery help forum

Install database erro

Hi there. We are installing biobakery_workflows on our local machine using conda install -c biobakery biobakery_workflows. When we installed the databases, using
biobakery_workflows_databases --install wmgx, we received the error below. We tried wmgx_demo, 16S, and wmgx_wmgx, and received the same error in all cases. Could you help us to understand what our error is when installing the databases? It would be much appreciated.

Have a great day!

(base) biolab@FH-BIOLAB-IMAC ~ % conda install -c biobakery biobakery_workflows

(base) biolab@FH-BIOLAB-IMAC ~ % biobakery_workflows_databases --install wmgx

Traceback (most recent call last):
File “/Users/biolab/opt/miniconda3/bin/biobakery_workflows_databases”, line 6, in
from biobakery_workflows.biobakery_workflows_databases import main
File “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/biobakery_workflows/biobakery_workflows_databases.py”, line 30, in
from . import utilities
File “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/biobakery_workflows/utilities.py”, line 34, in
from anadama2.tracked import TrackedDirectory
File “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/anadama2/init.py”, line 83, in
from .workflow import Workflow
File “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/anadama2/workflow.py”, line 24, in
from . import backends
File “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/anadama2/backends.py”, line 7, in
import leveldb
ModuleNotFoundError: No module named ‘leveldb’

Hi, Thank you for the detailed post. It looks like you are missing a dependency which is causing the error. If you install leveldb with conda or pypi it should resolve the issue.

Thank you,
Lauren

Lauren-
Thank you so much for your quick and perfect response. I installed leveldb and was successful…at first! I downloaded the HUMAnN database but then ran into an error when strainphlan was being generated (please see below). Again, any advice would be really appreciated.

HUMAnN configuration file updated: database_folders : utility_mapping = /Users/biolab/biobakery_workflows_databases/humann/utility_mapping

Generating strainphlan fasta database

Could not locate a Bowtie index corresponding to basename “/Users/biolab/opt/miniconda3/lib/python3.8/site-packages/metaphlan/metaphlan_databases/mpa_v30_CHOCOPhlAn_201901”

Error: Encountered internal Bowtie 2 exception (#1)

Command: /Users/biolab/opt/miniconda3/bin/bowtie2-inspect-s --wrapper basic-0 /Users/biolab/opt/miniconda3/lib/python3.8/site-packages/metaphlan/metaphlan_databases/mpa_v30_CHOCOPhlAn_201901

Unable to install database. Error running command: bowtie2-inspect /Users/biolab/opt/miniconda3/lib/python3.8/site-packages/metaphlan/metaphlan_databases/mpa_v30_CHOCOPhlAn_201901 > /Users/biolab/biobakery_workflows_databases/strainphlan_db_markers/all_markers.fasta

Hi @Bernadette_Connors , Can you install the MetaPhlAn database? The workflows use that database to generate the StrainPhlAn database.

Thank you,
Lauren