Humann3 does not recognize "relative abundance" in metaphlan profile file

Hi,

Thank you for developing these helpful tools! I am working with humann3 recently. I realised that current version of humann3 will not correctly read relative abundance results from metaphlan3 output profile file, when “estimated_number_of_reads_from_the_clade” is included in the profile. Instead, it will take the “coverage” column as “relative abundance” and do to downstream analysis. Therefore, it will ignore many species. I fixed this by reformat the profile file and get rid of the “estimated_number_of_reads_from_the_clade” column. I thought it would be helpful to post this issue here. Hope this can be fixed in the future version.

Best wishes,
AuAs

Hello - Thank you for the detailed post. Would you (if you have not already) double check that you have the most recent version of HUMAnN v3 installed? If you do have the most recent version and you still see the error would you provide a small example input file that replicates the error that you are seeing.

Thank you,
Lauren

Dear Lauren,

Sorry for the late response. I checked the version is humann v3.0.0.alpha.4

I solved the problems by removing “estimated_number_of_reads_from_the_clade” column in metaphlan profile files. It seems that the software cannot recognise “relative abundance” column when “estimated_number_of_reads_from_the_clade” column is there.

Sorry but I do not have the output demo at this moment. But I think this problem can be reproduce by using metaphlan profile file with “estimated_number_of_reads_from_the_clade”

Best wishes,
Shen

Hi Shen, Thank you for the follow up! Can you let me know the command and demo input file you used to generate the metaphlan profile that you ran with? If so then I can recreate the demo file you have and try to reproduce the problem on our end.

Thank you!
Lauren

Hi Lauren,

It’s great to hear from you. I am running metaphlan with the command:

cat {0} {1} | metaphlan --unknown_estimation --nproc 8 --input_type fastq -t rel_ab_w_read_stats -s {2}/{3}.sam --bowtie2out {4}/{3}.bowtie2.out > {5}/{3}.profile.txt

Seems that “rel_ab_w_read_stats” flag will add an additional column. Which cause problem in Humann when using the profile file as input.

Best wishes,
Shen