Got "local variable 'MINimum' referenced before assignment" while running

Hello! I’m new here and I have been redirected from GitHub, I hope the format I used there is ok.

Running Humann 3.6 (from a Galaxy Singularity image) using as database mpa_vJan21_CHOCOPhlAnSGB_202103, the program exited with error.

Full command:

humann \ -i “2MO24h.fq.gz” -o “out” \ –nucleotide-database $DB/chocophlan \ –protein-database $DB/uniref \ –metaphlan-options=" --index mpa_vJan21_CHOCOPhlAnSGB_202103 --bowtie2db $DB/mpa " \ –threads 24

I paste the log from the last successful messages to the traceback:

 Total gene families after translated alignment: 233101
  Unaligned reads after translated alignment: 24.0780298738 %
  Computing gene families ...
  Computing pathways abundance and coverage ...

Command error:
  Traceback (most recent call last):
    File "/usr/local/lib/python3.10/site-packages/humann/quantify/", line 934, in <module>
      Orth2Path(infile = anyfile, mpsfile = mpsfile, reportfile = reportfile, detailfile = detailfile, whichdb = "ANY", mapfile=mapfile)
    File "/usr/local/lib/python3.10/site-packages/humann/quantify/", line 901, in Orth2Path
      map = test.Orth2PathMin(famidxlist=[], famnamelist=orthlist, famcount=orthcount, mpsfile=mpsfile)
    File "/usr/local/lib/python3.10/site-packages/humann/quantify/", line 576, in Orth2PathMin
    File "/usr/local/lib/python3.10/site-packages/humann/quantify/", line 671, in GetLPOut
      if len(keeppath) != MINimum:
  UnboundLocalError: local variable 'MINimum' referenced before assignment
  CRITICAL ERROR: Unable to process all thread commands.
  Error message returned from command for thread task 42: /usr/local/bin/python3.10 /usr/local/lib/python3.10/site-packages/humann/quantify/ -any out/2MO24h_humann_temp/tmplsqts9nu/tmpsijjmk4n -map out/2MO24h_humann_temp/tmplsqts9nu/tmpebjakbhe -report out/2MO24h_humann_temp/tmplsqts9nu/tmpd5zbfro7 -details out/2MO24h_humann_temp/tmplsqts9nu/tmpditlrqyy -mps out/2MO24h_humann_temp/tmplsqts9nu/tmp27b6n9ua

In the output directory there are these files:

  • 2MO24h_genefamilies.tsv
  • 2MO24h_humann_temp/ (contains the whole 2MO24h_metaphlan_bugs_list.tsv)

The line triggering the error seems to be neede while parsing a file (in my case 2MO24h_humann_temp/tmplsqts9nu/tmp27b6n9ua.LPout), which starts with:

Problem:    PATH
Rows:       73
Columns:    209 (209 integer, 209 binary)
Non-zeros:  362
Objective:  NUM = 38 (MINimum)

and the line with “Objective” has no tabs in it.

Do you have any guidance? With some samples this command worked, with others got this error.

Thanks a million!

Hello, Thanks for the detailed post! I have not seen that error before. Did you see any errors during the glpsol step? I wonder if somehow the workflow ended up with some partial output files which it tried to then read downstream.