The bioBakery help forum

Error while executing raxmlHPC-PTHREADS-SSE3

Hello everyone,

I am trying to use the phylophlan3 concatenation tree pipeline to construct a tree using proteomes. I received an error message while the program is executing RAxML.

[e] Command ‘[’/scratch/c/careg421/ruizhang/standard-RAxML-8.2.12/raxmlHPC-PTHREADS-SSE3’, ‘-m’, ‘PROTCATLG’, ‘-f’, ‘a’, ‘-x’, ‘12345’, ‘-p’, ‘12345’, ‘-N’, ‘autoMRE’,
‘-T’, ‘20’, ‘-t’, ‘/scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_resolved.tre’, ‘-w’, ‘/scratch/c/careg421/ruizhang/phylophlan3_output/h
gcA_genomes1’, ‘-s’, ‘/scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_concatenated.aln’, ‘-n’, ‘hgcA_selected_refined.tre’]’ returned non-z
ero exit status 255.

[e] error while executing
command_line: /scratch/c/careg421/ruizhang/standard-RAxML-8.2.12/raxmlHPC-PTHREADS-SSE3 -m PROTCATLG -f a -x 12345 -p 12345 -N autoMRE -T 20 -t /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_resolved.tre -w /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1 -s /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_concatenated.aln -n hgcA_selected_refined.tre

Here is the command I used:

phylophlan -i $genomes
-d phylophlan
–databases_folder phylophlan3_db
-f supermatrix_aa.cfg
–diversity low
–accurate
-o $output
–nproc 80

The configuration file used was one of the defualts, with slight modifications to the RAxML parameters. (see error message)

I tried to toubleshoot by running the command /scratch/c/careg421/ruizhang/standard-RAxML-8.2.12/raxmlHPC-PTHREADS-SSE3 -h, and it seems RAxML works fine, so I am not sure why there is an issue executing the program within phylophlan.

BTW, I installed the software using pip, and ran the program under a virutal python environment in a university HPC, rather than conda. Phylophlan version is 3.0.2. RAxML version is 8.2.12.

Any insights as to what might have caused this issue? Thank you!

Rui

Hello Rui, thank you for reporting this.
Have you tried running the RAxML command as printed in the error message? (be aware that if you now have temp files from the previous RAxML execution you might need to either remove them or change the label with the -n param)

/scratch/c/careg421/ruizhang/standard-RAxML-8.2.12/raxmlHPC-PTHREADS-SSE3 -m PROTCATLG -f a -x 12345 -p 12345 -N autoMRE -T 20 -t /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_resolved.tre -w /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1 -s /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_concatenated.aln -n hgcA_selected_refined.tre

Many thanks,
Francesco

Thank you @f.asnicar for your prompt response! I ran the above command and received an error message Error, starting tree(s) will be ignored by rapid Bootstrapping.

However, since it mentioned about the starting tree, I removed the -t /scratch/c/careg421/ruizhang/phylophlan3_output/hgcA_genomes1/hgcA_selected_resolved.tre parameter, and it worked.

Sorry, I have limited knowledge in phylogenetics, I am not sure if this action will have any undesired consequences to the results. Also, since RAxML doesn’t like what is specified in the -t parameter, should I remove it from the configuration file whenever I need to generate bootstrap values?

Much appreciated!
Rui

Thanks Rui for trying the command. I don’t think that should be a problem. The tree passed with the -t param is used as a starting phylogeny for RAxML (and this doesn’t work when you want to do bootstrap).

If you want to run RAxML with the same parameters set in the future, my suggestion is to remove the [tree1] section from the config file (as you don’t need the phylogeny built with FastTree) and change your current [tree2] section that contains the RAxML parameters to [tree1]. After doing that you need also to make sure to remove the line:

database: -t

and the #database# from the command_line.

Alternatively, you can generate a new config file with phylophlan_write_config_file specifying only RAxML for the phylogeny reconstruction (--tree1 raxml) and then you can edit it by adding your bootstrap parameter.

Many thanks,
Francesco

1 Like

Thank you so much for your thorough explanations, this is hugely helpful!