Difficulty indexing reference database for metaphlan4


I am having trouble with building the index for metaphlan4. The download seems to work ok but the build step stalls after creating the bt2l .3 and .4 files. I initially tried within the miniconda environment but then I tried outside the environment and also just by using bowtie2 (on the fna file that the metaphlan -index command created) but it was same either way.

I have Bowtie version The command for bowtie was:

bowtie2-build ~/reference_databases/mpa_vJan21_CHOCOPhlAnSGB_202103.fna mpa_vJan21_CHOCOPhlAnSGB_202103 -f -threads 4

It stalls (or seems to) at the same point and the traceback call is the message displayed after I abandon the process


Hi @lorcan1601
It seems your machine does not have enough memory to build the indexes. You can find here: Index of /biobakery4/metaphlan_databases/bowtie2_indexes the already pre-built indexes

Thank you for your reply, Aitor and thank you for the link to the prebuilt indexes!

My computer has decided to try this time and it seems bowtie2 is working!! That said, it’s 7 hours and counting…

My computer has 16GB of RAM (which was fine for the previous version of metaphlan). Will this be enough for running Metaphlan?

Hi @lorcan1601 depending on the overall load of your machine it might be not enough