MetaPhlan4 No MetaPhlAn BowTie2 database found

Hello,
I have several issues with the databases when I am using MetaPhlan4, I dowloaded the latest version of the databases and installed it. Didn’t work for the last versions of MetaPhlan and neither for this one (the lastest). I am always having this error:
‘’’
No MetaPhlAn BowTie2 database found (–index option)!

Expecting location bowtie2db
‘’’
The command I run is:


metaphlan \
 /scratch/mblanco/baro/metagenomic/analysis/4_biobakery/F123_D49/kneaddata/main/F123_D49.fastq \
 --input_type fastq \
 --output_file /scratch/mblanco/baro/metagenomic/analysis/4_biobakery/F123_D49/metaphlan/main/F123_D49_taxonomic_profile.tsv \
 --samout /scratch/mblanco/baro/metagenomic/analysis/4_biobakery/F123_D49/metaphlan/main/F123_D49_bowtie2.sam \
 --nproc 24 \
 --no_map \
 --tmp_dir /scratch/mblanco/baro/metagenomic/analysis/4_biobakery/F123_D49/metaphlan/main \
 --bowtie2db /scratch/mblanco/metaphlan_db \
 -x mpa_vJan21_CHOCOPhlAnSGB_202103

I tried everything, I already read old post about this recurrent problem and I downloaded and indexed the datases several times, any idea or help would be very appreciated.
Thanks in advance,
Miguel

Hi @MiguelB
Can you show me the content of the /scratch/mblanco/metaphlan_db folder ?

Hi Aitor,
sorry for the late reply. Here are the files in the folder:

mpa_latest                              mpa_vJan21_CHOCOPhlAnSGB_202103.3.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103.pkl         mpa_vJan21_CHOCOPhlAnSGB_202103.tar
mpa_vJan21_CHOCOPhlAnSGB_202103.1.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103.4.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103.rev.1.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103_VINFO.csv
mpa_vJan21_CHOCOPhlAnSGB_202103.2.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103.md5     mpa_vJan21_CHOCOPhlAnSGB_202103.rev.2.bt2l  mpa_vJan21_CHOCOPhlAnSGB_202103_VSG.fna

thanks!