Metaphlan3 database issue

Hi,
I have been trying to use metaphlan3 which was recently install by our HPC admins. I’m getting stuck at the first step of the tutorial.

When I run the following: metaphlan SRS014476-Supragingival_plaque.fasta.gz --input_type fasta > SRS014476-Supragingival_plaque_profile.txt

I get the following error: Unable to create folder for database install: /usr/local/metaphlan/3.0/lib/python3.7/site-packages/metaphlan/metaphlan_databases

when I use --bowtie2db to point to a directory that I have write permissions for, the database files seem to download ok but the database build never finishes, it just stalls once it reaches a certain point. The following files are in the database directory where they should be, but one of the files “mpa_v30_CHOCOPhlAn_201901.2.bt2” is empty.

  • mpa_v30_CHOCOPhlAn_201901.3.bt2
  • mpa_v30_CHOCOPhlAn_201901.md5
  • mpa_latest
  • mpa_v30_CHOCOPhlAn_201901.4.bt2
  • mpa_v30_CHOCOPhlAn_201901.pkl
  • mpa_v30_CHOCOPhlAn_201901.1.bt2
  • mpa_v30_CHOCOPhlAn_201901.fna
  • mpa_v30_CHOCOPhlAn_201901.tar
  • mpa_v30_CHOCOPhlAn_201901.2.bt2
  • mpa_v30_CHOCOPhlAn_201901.fna.bz2

I run into the same issues when I try metaphlan --install.
Any ideas what may be going on?

Thanks!

Have you tried to build the database using directly bowtie2-build?
The command line to be used is bowtie2-build -f mpa_v30_CHOCOPhlAn_201901.fna mpa_v30_CHOCOPhlAn_201901.

This could help to see if any errors are raising during the build process

1 Like

Thanks for the reply - it was a memory issue (running bowtie2-build identified this) and it seems to be working fine now. Thanks again for your help!