The bioBakery help forum

CRITICAL ERROR: translated database uniref50_20190

Hi,

I installed the humann3 freshly though bioconda and once completed I installed the databases using the following commands

humann_databases --download chocophlan full HUMANN3
humann_databases --download uniref uniref90_diamond HUMANN3
humann_databases --download uniref uniref90_ec_filtered_diamond HUMANN3
humann_databases --download uniref uniref50_diamond HUMANN3
humann_databases --download uniref uniref50_ec_filtered_diamond HUMANN3

humann_config

database_folders : nucleotide = HUMANN3/chocophlan
database_folders : protein = HUMANN3/uniref
database_folders : utility_mapping = humann/3.0.0/lib/python3.7/site-packages/humann/data/misc
run_modes : resume = False
run_modes : verbose = False
run_modes : bypass_prescreen = False
run_modes : bypass_nucleotide_index = False
run_modes : bypass_nucleotide_search = False
run_modes : bypass_translated_search = False
run_modes : threads = 1
alignment_settings : evalue_threshold = 1.0
alignment_settings : prescreen_threshold = 0.01
alignment_settings : translated_subject_coverage_threshold = 50.0
alignment_settings : translated_query_coverage_threshold = 90.0
alignment_settings : nucleotide_subject_coverage_threshold = 50.0
alignment_settings : nucleotide_query_coverage_threshold = 90.0
output_format : output_max_decimals = 10
output_format : remove_stratified_output = False
output_format : remove_column_description_output = False

Run Command

humann --input Sample01.fastq.gz --output Sample01 --bypass-prescreen  --bypass-nucleotide-index  --verbose

Verbose:ERROR

Output files will be written to: Sample01
Writing temp files to directory: Sample01/Sample01_humann_temp
File (SE/Sample01.fastq.gz ) is of format:  fastq.gz
Decompressing gzipped file ...

CRITICAL ERROR: The directory provided for the translated database contains files ( uniref50_201901.dmnd ) that are not of the expected version. Please install the latest version of the database: 201901b

chocophlan

...
g__Zunongwangia.s__Zunongwangia_atlantica.centroids.v296_v201901b.ffn.gz
g__Zunongwangia.s__Zunongwangia_mangrovi.centroids.v296_v201901b.ffn.gz
g__Zunongwangia.s__Zunongwangia_profunda.centroids.v296_v201901b.ffn.gz
g__Zymomonas.s__Zymomonas_mobilis.centroids.v296_v201901b.ffn.

Urinref databases

uniref50_201901b_ec_filtered.dmnd 
uniref90_201901b_ec_filtered.dmnd
uniref90_201901b_full.dmnd 
uniref50_201901.dmnd

Secondly: I have an error with bowtie2 withe error

error while loading shared libraries: libtbb.so.2:

I have overcome with loading my bowtie2 module (2.4.2 ) for now

Hi,

I tried to make a copy of uniref50_201901.dmnd to uniref50_201901b.dmnd and run the program. but its still shows the same error

To use the most recent version of HUMAnN (3.0.0) you’ll need to download the most recent (201901b) translated search database. Simply renaming the old database will not work (it will not be compatible with the version of DIAMOND called by v3.0.0). In addition, assuming you want to hang onto the previous database (201901), you will want to store the new database in another folder.

I thought by running the above commands it will download the new files automatically. Can you please let me know which commands should I Run

You would need to add --update-config yes at the end of those commands for HUMAnN to automatically start pointing to the new databases. If you’ve already downloaded the updates but they’re not plugged into your installation, you can fix that by running the humann_config utility separately (i.e. you don’t have to redownload the databases).