Cladogram image not showing all species

I am trying to plot cladogram in Galaxy/Hutlab. The cladogram does not show all the species names in the legend which are represented in the image. I would really appreciate some insight into this matter.

It looks like you have many features that are differentially expressed in your dataset. To highlight the strongest associations (and remove visual clutter from the plot) I’d recommend increasing your LDA threshold from the default (2.0) to a higher value (4.0 is a good start).
I hope that helps!

Hi ,

Thank you for the suggestion. That helps in getting the complete legend. But is there a way to get the complete legend even when the LDA score is low. I have seen in some papers they go upto d0. Is there a way to get that done here.


Hi @Ann_Alex,

If I am understanding your question correctly in which you want the legend for the species on the side to not get cut off, the only way I know to do this is to work with the GraPhlAn object directly and call the flag --external_legends, which will print that legend off into a separate file that you can then play with in whatever image software you want.

For a good GraPhlAn tutorial, you can check out this page Home · biobakery/graphlan Wiki · GitHub.

I hope this helps.