Can't call for

Hi, I am running humann2, but there is an error: can not call software version for
Now, the version of humann2 is 2.8.1 and version of is 2.96.1.
I have tried many different versions of, but still did not work. So, which version of should I use or are there other problems according to this error?
Please help me! Thank you very much!


I am having the same issue, just my metaphlan2 version is 2.7.7.

Did you find any solution?


Hi, I have solved my problems. The version 2.6.0 is nice. I hope it is helpful to you.

Best wishes!


Thank you. Version 2.6.0 of humann2 or metaphlan2? I got a bit confused here :slight_smile:

I will try it out and let you know.


Sorry, I did not say it clearly. I used humann2-2.8.1 and metaphlan2-2.6.0.

Best wishes!

Hello, Sorry for the slow response. It is likely there is an error or other informative message when humann v2 tries to call the metaphlan v2 version. Try running: $ --version. The message is likely related to biom-format not being installed. Once you resolve this message humann v2 should be able to call the metaphlan v2 version.

Thank you,