Can we increase the percent identity threshold for metaplan when running humann3


I have simulated a metagenome sample from known species. When running humann3 for this metagenome sample, during metaphlan stage some reads are matching to a species that does not exist as an input. I bowtie2’ed the simulated reads against the species that matahplan output gives and there is 60-70% read match. I wonder if I can increase the percent identity threshold for metaphlan option when running humann3 so that the metagenomic reads will not match with other species.

Thank you for your help,

Hello, When running HUMAnN you can provide any options you would like to set for MetaPhlAn by using the option --metaphlan-options <option>.

Thank you,