Version differences

Hi, LefSe version 1.0 and version 1.1.01 gives different result in command line (same parameters used).

Lefse analysis version 1.1.01 gives this result:
Number of significantly discriminative features: 117 ( 117 ) before internal wilcoxon
Number of discriminative features with abs LDA score > 2.0 : 66

Lefse analysis version 1 gives this result:
Number of significantly discriminative features: 26 ( 117 ) before internal wilcoxon
Number of discriminative features with abs LDA score > 2.0 : 26

I could not find the improvements applied on the new version, so I could not choose which version is better actually.

Can you comment on what is the differences in both versions of LEfSe?

Thanks in advance…

Hi @UGG ,
Thank you for reaching out to biobakery lab and apologies for getting back to you late.

Can you try using the latest version 1.1.2 of lefse please and let us know if you see any improvements? We do not support the older versions of lefse so we do recommend using the latest version 1.1.2.

Additionally, is it possible for you to point us at the LefSe version 1.0 and version 1.1.01 that you are using please (links)? I might have to reach out to the original authors of the tool to track down exact version differences on LDA scores.

Version 1.1.2



I have installed LEfSe version 1.1.2 on our Linux server. To validate my installation, I tried to run the tutorial data (hmp_small_aerobiosis.txt) on Galaxy and on our Linux server using Galaxy’s default parameters. I found the results are different and I was not able to pinpoint the cause. I am attaching my results (LEfSe Results (Local Server vs Galaxy).xlsx) and I wonder if anyone can give me any suggestions on the cause?

I have considered that one possible cause is because of the software version differences, but I was not able to check the software versions on Galaxy, I believe only Galaxy administrators have the privilege to do that. I would be grateful if a bioBakery team member can provide me the software versions on Galaxy.

Version in Galaxy Version in Our Linux server
LEfSe ? 1.1.2
Python ? 3.9.6
rpy2 (python package) ? 3.4.5
R ? 4.1.1
survival (R package) ? 3.2.12
mvtnorm (R package) ? 1.1.2
modeltools (R package) ? 0.2.23
coin (R package) ? 1.4.1
MASS (R package) ? 7.3.54

Thanks & Regards,

I found some mistakes in “LEfSe Results (Local Server vs Galaxy).xlsx”, and I just amended them.
Apologies if I have caused inconvenience to anyone.


Hi Sagun,

I am having the same issue. Could you share the code for updating lefse to version 1.1.2 ?

I have biobakery3 installed via conda and lefse (1.1.01) came along with the installation. I tried to update the package within biobakery3 using:
conda install -c biobakery lefse=1.1.2

However it did not work for me and the lefse version still stays at 1.1.01


Hi @Shuqi_Li ,

Thank you for reaching out to biobakery Lab. It seems that you are having problem with the conda upgrade.
Can you try the pip installation please (lefse · PyPI)?

python3 -m pip install lefse

Manual Installation is also available for v1.1.2 through:

git clone
cd lefse
python3 install


But still with TypeError.

Traceback (most recent call last):
File “/home/people/binson/.local/bin/”, line 8, in
File “/home/people/binson/.local/lib/python3.10/site-packages/lefse/”, line 177, in plot_res
else: plot_histo_hor(params[‘output_file’],params,data,len(data[‘cls’]) == 2,params[‘report_features’])
File “/home/people/binson/.local/lib/python3.10/site-packages/lefse/”, line 104, in plot_histo_hor
if len(rr) > params[‘max_feature_len’]: rr = rr[:params[‘max_feature_len’]/2-2]+" […]"+rr[-params[‘max_feature_len’]/2+2:]
TypeError: slice indices must be integers or None or have an index method

–max_feature_len 20 will cause the above error, but --max_feature_len 25 won’t.